Как в excel распространить формулу на весь столбец

Как использовать вычисляемые столбцы в таблице Excel

Вычисляемые столбцы в таблицах Excel упрощают ввод формул. Формула, введенная в одну ячейку столбца, автоматически распространяется на его остальную часть. При этом не приходится использовать заполнение или копирование. Это позволяет сэкономить время, особенно при наличии множества строк. То же самое происходит при изменении формулы: изменение также распространяется на все остальные ячейки вычисляемого столбца.

Примечание: Снимки экрана в этой статье получены в Excel 2016. Если вы используете другую версию, интерфейс может немного отличаться, но функции будут такими же.

Создание вычисляемого столбца

Создайте таблицу. Если вы не знакомы с таблицами Excel, см. статью Общие сведения о таблицах Excel.

Вставьте в таблицу новый столбец. Введите данные в столбец справа от таблицы, и Excel автоматически расширит ее. В этом примере мы создали новый столбец, введя «Итог» в ячейке D1.

Вы также можете добавить столбец на вкладке Главная. Просто щелкните стрелку на кнопке Вставить и выберите команду Вставить столбцы таблицы слева.

Введите нужную формулу и нажмите клавишу ВВОД.

В этом случае мы ввели =СУММ(, а затем выбрали столбцы Кв1 и Кв2. В результате Excel создал следующую формулу: =СУММ(Таблица1[@[Кв1]:[Кв2]]). Такие формулы называются формулами со структурированными ссылками, и их можно использовать только в таблицах Excel. Структурированные ссылки позволяют использовать одну и ту же формулу в каждой строке. Обычная формула Excel выглядела бы как =СУММ(B2:C2), и ее было бы необходимо добавить в остальные ячейки путем копирования и вставки или заполнения.

Дополнительные сведения о структурированных ссылках см. в статье Использование структурированных ссылок в таблицах Excel.

При нажатии клавиши ВВОД формула будет автоматически применена ко всем ячейкам столбца, которые находятся сверху и снизу от активной ячейки. Для каждой строки используется одна и та же формула, но поскольку это структурированная ссылка, Excel знает, на что она ссылается в каждой строке.

При копировании формулы во все ячейки пустого столбца или заполнении его формулой он также становится вычисляемым.

Если ввести или переместить формулу в столбец, уже содержащий данные, это не приведет к автоматическому созданию вычисляемого столбца. Однако отобразится кнопка Параметры автозамены, с помощью которой можно перезаписать данные и создать вычисляемый столбец.

При вводе новой формулы, которая отличается от существующих в вычисляемом столбце, она будет автоматически применена к столбцу. Вы можете отменить обновление и оставить только одну новую формулу, используя кнопку Параметры автозамены. Обычно не рекомендуется этого делать, так как столбец может прекратить автоматически обновляться из-за того, что при добавлении новых строк будет неясно, какую формулу нужно к ним применять.

Если вы ввели или скопировали формулу в ячейку пустого столбца и не хотите использовать новый вычисляемый столбец, нажмите Отменить два раза. Вы также можете дважды нажать клавиши CTRL+Z.

В вычисляемый столбец можно включать формулы, отличающиеся от формулы столбца. Ячейки с такими формулами становятся исключениями и выделяются в таблице. Это позволяет выявлять и устранять несоответствия, возникшие по ошибке.

Примечание: Исключения вычисляемого столбца возникают в результате следующих операций.

При вводе в ячейку вычисляемого столбца данных, отличных от формулы.

Ввод формулы в ячейку вычисляемого столбца и нажатие кнопки Отменить на панели быстрого доступа.

Ввод новой формулы в вычисляемый столбец, который уже содержит одно или несколько исключений.

При копировании в вычисляемый столбец данных, которые не соответствуют формуле вычисляемого столбца.

Примечание: Если скопированные данные содержат формулу, она заменяет данные в вычисляемом столбце.

При удалении формулы из одной или нескольких ячеек вычисляемого столбца.

Примечание: В этом случае исключение не помечается.

При удалении или перемещении ячейки в другую область листа, на которую ссылается одна из строк вычисляемого столбца.

Уведомление об ошибке отображается только в том случае, если включена фоновая проверка ошибок. Если вы не видите сообщение об ошибке, откройте Файл > Параметры > Формулы и убедитесь, что флажок Включить фоновую проверку ошибок установлен.

Если вы используете Excel 2007, нажмите кнопку Office и выберите Параметры Excel > Формулы.

Если вы используете Mac, в строке меню Excel выберите Параметры > Формулы и списки > Поиск ошибок.

Параметр автоматического заполнения формул для создания вычисляемых столбцов в таблице Excel по умолчанию включен. Если не нужно, чтобы приложение Excel создавало вычисляемые столбцы при вводе формул в столбцы таблицы, можно выключить параметр заполнения формул. Если вы не хотите выключать этот параметр, но не всегда при работе с таблицей хотите создавать вычисляемые столбцы, в этом случае можно прекратить автоматическое создание вычисляемых столбцов.

Читать еще:  Excel количество значений формула

Включение и выключение вычисляемых столбцов

На вкладке Файл нажмите кнопку Параметры.

Если вы используете Excel 2007, нажмите кнопку Office и выберите Параметры Excel.

Выберите категорию Правописание.

В разделе Параметры автозамены нажмите кнопку Параметры автозамены

Откройте вкладку Автоформат при вводе.

В разделе Автоматически в ходе работы установите или снимите флажок Создать вычисляемые столбцы, заполнив таблицы формулами, чтобы включить или выключить этот параметр.

«Средства проверки правописания» > «Параметры автозамены» и снятия флажка «Создать вычисляемые столбцы, заполнив таблицы формулами».» />

Совет: Вы можете также щелкнуть кнопку Параметры автозамены, которая отобразится в столбце таблицы после ввода формулы. Нажмите кнопку Параметры автозамены, а затем снимите флажок Создать вычисляемые столбцы, заполнив таблицы формулами, чтобы отключить этот параметр.

Если вы используете Mac, выберите Excel в главном меню, а затем щелкните Параметры > Формулы и списки > Таблицы и фильтры > Автоматически заполнять формулы.

Прекращение автоматического создания вычисляемых столбцов

После ввода в столбец таблицы первой формулы нажмите отобразившуюся кнопку Параметры автозамены, а затем выберите Не создавать вычисляемые столбцы автоматически.

Вычисляемые поля можно также создавать в сводных таблицах. При этом Excel будет применять созданную формулу ко всему столбцу. Подробнее о вычислении значений в сводных таблицах.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community, попросить помощи в сообществе Answers community, а также предложить новую функцию или улучшение на веб-сайте Excel User Voice.

Как в экселе растянуть формулу на весь столбец?

В программе эксель часто требуется написанную формулу в одной ячейке растянуть сразу на весь столбец. Но при этом данная задача может вызвать много вопросов у людей, только начинающих пользоваться данной программой. Поэтому давайте рассмотрим пошаговую инструкцию, как в программе эксель растянуть формулу на весь столбец.

Первый шаг. Возьмем таблицу, состоящую из трех столбцов: Число №1, Число №2, Сумма. Задача написать для первой ячейки формулу, а потом в одно действие её растянуть на весь столбец.

Второй шаг. Поставим курсор в ячейку «С2» и напишем простую суммирующую формулу: =A2+B2, где А2 – первое число, В2 – второе число.

Третий шаг. Теперь выделяете ячейку «С2», после обращаете внимание, что в нижнем правом углу есть маленький едва видный квадратик.

Четвертый шаг. Вам остается навести курсор на этот квадрат и дважды нажать на него левой клавишей мыши. В итоге формулу автоматически распространится на весь столбец.

Как в excel применить формулу ко всему столбцу?

Если считаете, что Автозаполнение не даст гарантии, тогда сделайте всё вручную. Для того, чтобы применить формулу ко всему столбцу, необходимо, чтобы она находилась в первой строке. И, конечно, нижние ячеечки не должны быть заполнены.

Начинаем с того, что нажимаем Ctrl Shift, таким образом выделив весь наш столбец. Теперь Ctrl D. И начинается процесс заполнения.

Можно и так: на столбце, который мечтаем . собираемся заполнить, тыкаем курсорчиком в букву или цифру, чтоб его выделить, и далее Ctrl Enter. Моментально начнёт заполняться. Это легко и просто, но. при условии, что ваша формула проста.

Есть два варианта заполнения: 1) когда в формуле значения зафиксированы; 2) когда в формуле значения меняются, поскольку ячейки при смене конечной ячейки с итоговым значением перескакивают на равное количество клеток от исходной.

Рассмотрим эти два примера.

Набираем в ячейке формулу и фиксируем её значком доллара.

Для заполнения жёлтых ячеек на ячейке с формулой наживаем Ctrl+C. Выделяем жёлтые ячейки и нажимаем Ctrl+V.

Набираем в ячейке формулу и уже НЕ фиксируем её значком доллара.

Для заполнения жёлтых ячеек на ячейке с формулой наживаем Ctrl+C. Выделяем жёлтые ячейки и нажимаем Ctrl+V.

Если Вам действительно нужно применить формулу Excel ко всему столбцу (а не, например, к диапазону), то, очевидно, что эта формула должна находится в первой строке какого-либо столбца. Например, пусть формула находится в ячейке B1. Также очевидно, что ниже этой ячейки (сразу под ней — то есть в этом же столбце) все ячейки должны быть пустые, так как, если хотя бы в одной из них что-то будет, то Вы (применив формулу ко всему столбцу) затрете эти данные.

Активная ячейка (ее имя отображается в поле имени) обязательно должна быть B1

Последовательность действий — вариант 1:

Жмем (одновременное нажатие) — Ctrl Shift «стрелка вниз» (клавиша). После этого будет выделен весь столбец. Если у Вас Excel 2003 (или более ранний), то будет выделено 65536 ячеек, если Excel 2007 (или более поздняя версия) то будет выделено 1048576 ячеек.

Читать еще:  Как написать формулу в excel если то несколько условий примеры

Как Вам уже посоветовали — жмем сочетание клавиш Ctrl D.

Сразу после этого начнется заполнение всех ячеек этого столбца Вашей формулой.

ВАЖНО: если формула относительно сложная и ресурсоемкая, то Вам придется подождать какое-то время (иногда несколько секунд, иногда измеряется минутами). При этом, если формула по настоящему сложная, то Вы можете и не дождаться пока заполнится столбец (просто не хватит ресурсов Excel).

Вариант 2

Сразу выделяем весь столбец (для этого достаточно кликнуть по букве столбца)

Пишем формулу и вместо привычного Enter нажимает Ctrl Enter — и Excel заполнит Вашей формулой все ячейки.

Как использовать вычисляемые столбцы в таблице Excel

Вычисляемые столбцы в таблицах Excel упрощают ввод формул. Формула, введенная в одну ячейку столбца, автоматически распространяется на его остальную часть. При этом не приходится использовать заполнение или копирование. Это позволяет сэкономить время, особенно при наличии множества строк. То же самое происходит при изменении формулы: изменение также распространяется на все остальные ячейки вычисляемого столбца.

Примечание: Снимки экрана в этой статье получены в Excel 2016. Если вы используете другую версию, интерфейс может немного отличаться, но функции будут такими же.

Создание вычисляемого столбца

Создайте таблицу. Если вы не знакомы с таблицами Excel, см. статью Общие сведения о таблицах Excel.

Вставьте в таблицу новый столбец. Введите данные в столбец справа от таблицы, и Excel автоматически расширит ее. В этом примере мы создали новый столбец, введя «Итог» в ячейке D1.

Вы также можете добавить столбец на вкладке Главная. Просто щелкните стрелку на кнопке Вставить и выберите команду Вставить столбцы таблицы слева.

Введите нужную формулу и нажмите клавишу ВВОД.

В этом случае мы ввели =СУММ(, а затем выбрали столбцы Кв1 и Кв2. В результате Excel создал следующую формулу: =СУММ(Таблица1[@[Кв1]:[Кв2]]). Такие формулы называются формулами со структурированными ссылками, и их можно использовать только в таблицах Excel. Структурированные ссылки позволяют использовать одну и ту же формулу в каждой строке. Обычная формула Excel выглядела бы как =СУММ(B2:C2), и ее было бы необходимо добавить в остальные ячейки путем копирования и вставки или заполнения.

Дополнительные сведения о структурированных ссылках см. в статье Использование структурированных ссылок в таблицах Excel.

При нажатии клавиши ВВОД формула будет автоматически применена ко всем ячейкам столбца, которые находятся сверху и снизу от активной ячейки. Для каждой строки используется одна и та же формула, но поскольку это структурированная ссылка, Excel знает, на что она ссылается в каждой строке.

При копировании формулы во все ячейки пустого столбца или заполнении его формулой он также становится вычисляемым.

Если ввести или переместить формулу в столбец, уже содержащий данные, это не приведет к автоматическому созданию вычисляемого столбца. Однако отобразится кнопка Параметры автозамены, с помощью которой можно перезаписать данные и создать вычисляемый столбец.

При вводе новой формулы, которая отличается от существующих в вычисляемом столбце, она будет автоматически применена к столбцу. Вы можете отменить обновление и оставить только одну новую формулу, используя кнопку Параметры автозамены. Обычно не рекомендуется этого делать, так как столбец может прекратить автоматически обновляться из-за того, что при добавлении новых строк будет неясно, какую формулу нужно к ним применять.

Если вы ввели или скопировали формулу в ячейку пустого столбца и не хотите использовать новый вычисляемый столбец, нажмите Отменить два раза. Вы также можете дважды нажать клавиши CTRL+Z.

В вычисляемый столбец можно включать формулы, отличающиеся от формулы столбца. Ячейки с такими формулами становятся исключениями и выделяются в таблице. Это позволяет выявлять и устранять несоответствия, возникшие по ошибке.

Примечание: Исключения вычисляемого столбца возникают в результате следующих операций.

При вводе в ячейку вычисляемого столбца данных, отличных от формулы.

Ввод формулы в ячейку вычисляемого столбца и нажатие кнопки Отменить на панели быстрого доступа.

Ввод новой формулы в вычисляемый столбец, который уже содержит одно или несколько исключений.

При копировании в вычисляемый столбец данных, которые не соответствуют формуле вычисляемого столбца.

Примечание: Если скопированные данные содержат формулу, она заменяет данные в вычисляемом столбце.

При удалении формулы из одной или нескольких ячеек вычисляемого столбца.

Примечание: В этом случае исключение не помечается.

При удалении или перемещении ячейки в другую область листа, на которую ссылается одна из строк вычисляемого столбца.

Уведомление об ошибке отображается только в том случае, если включена фоновая проверка ошибок. Если вы не видите сообщение об ошибке, откройте Файл > Параметры > Формулы и убедитесь, что флажок Включить фоновую проверку ошибок установлен.

Читать еще:  Функция деления в excel

Если вы используете Excel 2007, нажмите кнопку Office и выберите Параметры Excel > Формулы.

Если вы используете Mac, в строке меню Excel выберите Параметры > Формулы и списки > Поиск ошибок.

Параметр автоматического заполнения формул для создания вычисляемых столбцов в таблице Excel по умолчанию включен. Если не нужно, чтобы приложение Excel создавало вычисляемые столбцы при вводе формул в столбцы таблицы, можно выключить параметр заполнения формул. Если вы не хотите выключать этот параметр, но не всегда при работе с таблицей хотите создавать вычисляемые столбцы, в этом случае можно прекратить автоматическое создание вычисляемых столбцов.

Включение и выключение вычисляемых столбцов

На вкладке Файл нажмите кнопку Параметры.

Если вы используете Excel 2007, нажмите кнопку Office и выберите Параметры Excel.

Выберите категорию Правописание.

В разделе Параметры автозамены нажмите кнопку Параметры автозамены

Откройте вкладку Автоформат при вводе.

В разделе Автоматически в ходе работы установите или снимите флажок Создать вычисляемые столбцы, заполнив таблицы формулами, чтобы включить или выключить этот параметр.

«Средства проверки правописания» > «Параметры автозамены» и снятия флажка «Создать вычисляемые столбцы, заполнив таблицы формулами».» />

Совет: Вы можете также щелкнуть кнопку Параметры автозамены, которая отобразится в столбце таблицы после ввода формулы. Нажмите кнопку Параметры автозамены, а затем снимите флажок Создать вычисляемые столбцы, заполнив таблицы формулами, чтобы отключить этот параметр.

Если вы используете Mac, выберите Excel в главном меню, а затем щелкните Параметры > Формулы и списки > Таблицы и фильтры > Автоматически заполнять формулы.

Прекращение автоматического создания вычисляемых столбцов

После ввода в столбец таблицы первой формулы нажмите отобразившуюся кнопку Параметры автозамены, а затем выберите Не создавать вычисляемые столбцы автоматически.

Вычисляемые поля можно также создавать в сводных таблицах. При этом Excel будет применять созданную формулу ко всему столбцу. Подробнее о вычислении значений в сводных таблицах.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community, попросить помощи в сообществе Answers community, а также предложить новую функцию или улучшение на веб-сайте Excel User Voice.

Как протянуть столбец в Excel

Рассмотрим несколько способов протягивания (копирования) формул в строках и столбцах программы Excel.

Первый способ: протянуть ячейку в столбце или строке.

Чтобы протянуть (распространить) формулу из одной ячейки в несколько ячеек столбца или строки следует выполнить ряд действий: 1. Записать функцию (формулу) в ячейку и нажать ENTER. 2. Навести курсор на нижний правый угол ячейки таким образом, чтобы он приобрел форму тонкого черного крестика. 3. Нажать и удерживать левую кнопку мыши.

4. Не отпуская кнопку мыши потянуть крестик в нужном направлении. В ту сторону, в которую следует распространить значение ячейки.

Для быстрого заполнения столбца формулой или значением из ячейки достаточно выполнить следующие действия: 1. Записать функцию (формулу) в ячейку и нажать «ENTER». 2. Навести курсор на нижний правый угол ячейки таким образом, чтобы он приобрел форму тонкого черного крестика.

3. Кликнуть двойным кликом по правому нижнему углу ячейки.

Формула протянется автоматически до первой пустой ячейки или до полной в случаях, когда в столбце после ячейки с размножаемой функцией стоят пустые ячейки.

Третий способ: протянуть формулу без изменения (смещения) исходных ячеек.

Для протягивания функции без ее изменения следует выполнить те же операции, что в первом и во втором случает. Только перед протягиванием нужно зафиксировать адреса неизменяемых ячеек. Зафиксировать адреса ячеек можно добавив перед значением адреса столбца или перед значением адреса строки знак «$»доллара.

Теперь, когда адрес закреплен, он не будет меняться при протягивании.

Четвертый способ: протянуть формулу при помощи копирования.

Подходит для работы под фильтрами. Выполняется следующим образом: 1. Записать функцию (формулу) в ячейку и нажать ENTER. 2. Копировать значение ячейки при помощи выпадающего контекстного меню правой кнопкой мыши или сочетанием клавиш «ctrl»+»c».

3. Выделить нужный диапазон. Для быстрого выделения вниз достаточно нажать сочетание клавиш: «Ctrl»+»shift»+ стрелка вниз Для быстрого выделения в сторону достаточно нажать сочетание клавиш: «Ctrl»+»shift»+ стрелка в сторону

  1. После того, как выделили диапазон, следует вставить скопированную формулу при помощи выпадающего контекстного меню правой кнопкой мыши или сочетанием клавиш «ctrl»+»v».

Похожие статьи

Ссылка на основную публикацию
Похожие публикации
Adblock
detector