Функция произведения в excel

Расчет суммы произведений в Excel

При выполнении некоторых расчетов требуется находить сумму произведений. Этот вид вычислений часто выполняют бухгалтера, инженеры, планировщики, учащиеся образовательных учреждений. Например, данный способ расчета востребован для сведения общего количества заработной платы за отработанные дни. Выполнение этого действия может понадобиться и в других отраслях, и даже для бытовых нужд. Давайте выясним, как в программе Excel можно рассчитать сумму произведений.

Вычисление суммы произведения

Из самого наименования действия понятно, что сумма произведений представляет собой сложение результатов умножения отдельных чисел. В Экселе это действие можно выполнить с помощью простой математической формулы или применив специальную функцию СУММПРОИЗВ. Давайте рассмотрим подробно эти способы в отдельности.

Способ 1: использование математической формулы

Большинству пользователей известно, что в Экселе можно выполнить значительное количество математических действий просто поставив знак «=» в пустой ячейке, а далее записав выражение по правилам математики. Этот способ можно использовать и для нахождения суммы произведений. Программа, согласно математическим правилам, сразу подсчитывает произведения, а уже потом складывает их в общую сумму.

  1. Устанавливаем знак «равно» (=) в ячейке, в которой будет выводиться результат производимых вычислений. Записываем туда выражение суммы произведений по следующему шаблону:

Например, таким способом можно рассчитать выражение:

Способ 2: работа со ссылками

Вместо конкретных чисел в этой формуле можно указывать ссылки на ячейки, в которых они расположены. Ссылки можно вписать вручную, но удобнее это делать, выделив после знака «=», «+» или «*» соответствующую ячейку, в которой содержится число.

    Итак, сразу записываем выражение, где вместо чисел указаны ссылки на ячейки.

  • Затем, чтобы произвести подсчет, кликаем по кнопке Enter. Результат вычисления будет выведен на экран.
  • Конечно, данный вид вычисления довольно простой и интуитивно понятный, но в случае, если в таблице очень много значений, которые нужно перемножить, а потом сложить, этот способ может занять очень много времени.

    Способ 3: использование функции СУММПРОИЗВ

    Для того, чтобы подсчитать сумму произведения, некоторые пользователи предпочитают специально предназначенную для этого действия функцию – СУММПРОИЗВ.

    Наименование данного оператора говорит о его предназначении само за себя. Преимущество этого способа перед предыдущим состоит в том, что с его помощью можно обрабатывать сразу целые массивы, а не выполнять действия с каждым числом или ячейкой в отдельности.

    Синтаксис данной функции имеет такой вид:

    Аргументами этого оператора являются диапазоны данных. При этом они сгруппированы по группам множителей. То есть, если отталкиваться от шаблона, о котором мы говорили выше (a1*b1*…+a2*b2*…+a3*b3*…+…), то в первом массиве располагаются множители группы a, во втором – группы b, в третьем – группы c и т.д. Данные диапазоны обязательно должны быть однотипными и равными по длине. Располагаться они могут, как вертикально, так и горизонтально. Всего данный оператор может работать с количеством аргументов от 2 до 255.

    Формулу СУММПРОИЗВ можно сразу записывать в ячейку для вывода результата, но многим пользователям легче и удобнее производить вычисления через Мастер функций.

      Выделяем ячейку на листе, в которой будет выводиться итоговый результат. Жмем на кнопку «Вставить функцию». Она оформлена в виде пиктограммы и располагается слева от поля строки формул.

    После того, как пользователь произвел данные действия, запускается Мастер функций. В нем открывается список всех, за малым исключением, операторов, с которыми можно работать в Экселе. Чтобы найти нужную нам функцию, переходим в категорию «Математические» или «Полный алфавитный перечень». После того, как нашли наименование «СУММПРОИЗВ», выделяем его и жмем на кнопку «OK».

    Запускается окно аргументов функции СУММПРОИЗВ. По количеству аргументов оно может иметь от 2 до 255 полей. Адреса диапазонов можно вбивать вручную. Но это займет значительное количество времени. Можно сделать несколько по-другому. Устанавливаем курсор в первое поле и выделяем с зажатой левой кнопкой мыши массив первого аргумента на листе. Таким же образом поступаем со вторым и со всеми последующими диапазонами, координаты которых сразу же отображаются в соответствующем поле. После того, как все данные введены, жмем на кнопку «OK» в нижней части окна.

  • После этих действий программа самостоятельно производит все требуемые вычисления и выводит итоговый результат в ту ячейку, которая была выделена в первом пункте данной инструкции.
  • Способ 4: применение функции по условию

    Функция СУММПРОИЗВ хороша и тем, что её можно применять по условию. Разберем, как это делается на конкретном примере.

    У нас есть таблица окладов и отработанных дней работников предприятия за три месяца помесячно. Нам нужно узнать, какую сумму на протяжении этого периода заработал сотрудник Парфенов Д.Ф.

      Тем же способом, что и в предыдущий раз, вызываем окно аргументов функции СУММПРОИЗВ. В первых двух полях указываем в качестве массивов соответственно диапазоны, где указана ставка сотрудников и количество отработанных ими дней. То есть, делаем все, как и в предыдущем случае. А вот в третьем поле задаем координаты массива, в котором содержатся имена сотрудников. Сразу же после адреса добавляем запись:

    После того, как все данные внесены, жмем кнопку «OK».

    Приложение производит вычисление. В расчет берутся только строчки, в которых присутствует имя «Парфенов Д.Ф», то есть то, что нам и нужно. Результат вычислений отображается в предварительно выделенной ячейке. Но результат равен нулю. Это связано с тем, что формула в том виде, в котором она существует сейчас, работает некорректно. Нам нужно её немного преобразовать.

    Читать еще:  Как посчитать количество ячеек в excel формула

  • Для того чтобы преобразовать формулу, выделяем ячейку с итоговым значением. Выполняем действия в строке формул. Аргумент с условием берем в скобки, а между ним и другими аргументами точку с запятой меняем на знак умножения (*). Жмем на кнопку Enter. Программа производит подсчет и на этот раз выдает уже корректное значение. Мы получили общую сумму заработной платы за три месяца, которая причитается сотруднику предприятия Парфенову Д. Ф.
  • Таким же образом можно применять условия не только к тексту, но и к числам с датами, добавляя знаки условия « », «=», « ».

    Как видим, существует два основных способа вычисления суммы произведений. Если данных не слишком много, то легче воспользоваться простой математической формулой. Когда же в вычислении участвует большое количество чисел, пользователь сбережет значительное количество своего времени и сил, если воспользуется возможностями специализированной функции СУММПРОИЗВ. Кроме того, с помощью этого же оператора можно производить вычисление по условию, что обычная формула не умеет делать.

    Отблагодарите автора, поделитесь статьей в социальных сетях.

    Примеры функции ПРОИЗВЕД для произведения расчетов в Excel

    Функция ПРИЗВЕД принимает в качестве аргументов два массива, содержащих как минимум по одному элементу, которые являются числовыми значениями, и возвращает результат перемножения (произведение) всех чисел, содержащихся в массивах.

    Например, запись =ПРОИЗВЕД(B1;C1) эквивалентная записи =B1*C1. Если были переданы ссылки на диапазоны ячеек =ПРОИЗВЕД(C7:C9;D7:D9), такая запись соответствует перемножению всех чисел в ячейках: =C7*C8*C9*D7*D8*D9. Как видно, функция ПРОИЗВЕД обеспечивает удобство выполнения операции произведения над числами, содержащимися в большом количестве ячеек. Несмотря на свою простоту эта функция открывает широкие возможности в Excel.

    Произведение корней квадратного уравнения в Excel

    Пример 1. В таблице содержатся числовые данные (несколько строк и столбцов). Вычислить корень квадратный произведения всех указанных чисел.

    Вид таблицы данных:

    Для расчета используем следующую формулу:

    =0;КОРЕНЬ(ПРОИЗВЕД(A2:D5));»отрицательное число»)’ class=’formula’>

    Поскольку корень отрицательного числа вычислить нельзя, используем функцию ЕСЛИ для проверки данных (результата вычисления функции ПРОИЗВЕД, принимающей ссылку на диапазон ячеек с числовыми данными в качестве единственного аргумента). Если полученное число является положительным или нулем, будет вычислен корень, иначе – выведено сообщение об ошибке.

    Как видно в данном примере возможности функции весьма существенны. Далее рассмотрим более практичный пример применения вычислений подобного рода.

    Расчет вероятности комбинаций в покере в Excel

    Пример 2. В колоде находятся 52 карты 4 разных мастей (всего по 13 карт). Определить вероятность события, когда из колоды последовательно вытаскивают и возвращают обратно 4 карты различной масти.

    Вид таблицы данных:

    Для расчета используем умножение вероятностей для определения логического произведения событий (то есть, их одновременное наступление). То есть, необходимо определить вероятности четырех событий (например, вытащена пика, трефа, черва и бубна) и найти их произведение.

    Вероятность первого события равна 1, поскольку карта любой масти будет уникальной (предшествующих событий нет). Вероятность второго и последующих событий определяется соотношением общего числа карт оставшихся мастей к числу карт во всей колоде, то есть 13 (число карт одной масти) * 3 (число оставшихся мастей)/52 – вероятность второго события.

    Определим искомые вероятности в Excel с помощью формул:

    Вычислим искомую вероятность с помощью функции:

    • 1 – определенная ранее вероятность первого события;
    • C4:C6 – диапазон ячеек с вероятностями последующих событий.

    Подобная запись (наличие чисел и ссылок на ячейки в качестве аргументов функции) также является допустимой.

    Правила использования функции ПРОИЗВЕД в Excel

    Функция имеет следующий синтаксис:

    =ПРОИЗВЕД( число1; [число2];…)

    • число1 – обязательный для заполнения, принимает числовое значение, ссылку на ячейку или диапазон ячеек с числовыми данными, которые необходимо перемножить;
    • [число2];… — второй и последующие необязательные аргументы, которые принимают числовые значения или ссылки на ячейки с числами, выступающими в роли второго и последующим множителей. Если явно не указан, принимается значение, равное 1. Например, =ПРОИЗВЕД(5) эквивалентно =5*1 и возвращает число 5. Максимальное число аргументов – 255.
    1. Функция выполняет промежуточные преобразования данных там, где это возможно, например, текстовые представления чисел, логические ИСТИНА и ЛОЖЬ. Например, =ПРОИЗВЕД(“3”;”6”) вернет значение 18, =ПРОИЗВЕД(3;ЛОЖЬ) вернет значение 0 (так как логическое ложь соответствует числовому 0).
    2. Если аргументы рассматриваемой функции указаны в виде ссылок на диапазоны ячеек, в некоторых из которых содержатся не преобразуемые к числам данные, функция исключит эти данные из расчетов. Например, результатом выполнения =ПРОИЗВЕД(A1:A4;B1:B4) будет число 144 ( в ячейках A1:A4 содержатся данные: 1, 2, 3, “текст”, в ячейках B1:B4 содержатся числа: 1, 2, 3, 4 соответственно).

    ITGuides.ru

    Вопросы и ответы в сфере it технологий и настройке ПК

    Как работает умножение чисел и ячеек в программе Excel

    Excel — программа для работы с таблицами, поэтому операции умножения являются базовыми основами работы с ней

    Microsoft Excel — это табличный процессор, который обладает достаточно мощным функционалом для работы с электронными таблицами. Среди многочисленных функций в этой программе стоит отметить самую простую — возможность работать с числами. Табличный процессор может выполнять как простые операции (сложение, умножение), так и более сложные: решение транспортных задач, подбор параметра, поиск оптимального решения и пр. Для ознакомления с программой на начальном уровне достаточно будет научиться выполнять простые операции вроде умножения чисел.

    Как в Экселе умножать числа?

    Для начала следует запомнить, что любые вычисления в Экселе называются формулами, и все они всегда начинаются со знака равно. То есть нужно выбрать любую пустую клеточку и ввести знак равно. Только после этого можно вводить какие-то данные. К примеру, можно написать так: =5*5 (символ звездочки — это знак умножения). Программа сразу же поймет, что от нее требуется и выдаст результат — 25.

    Читать еще:  Функция если в excel если ячейка содержит

    Если выделить поле, где выводится результат, то можно увидеть саму формулу, которая находится в поле формул (она располагается чуть выше, над рабочим листом Excel). Здесь же ее можно и редактировать. Например, можно дописать так: =5*5*10 (после этого результат тут же изменится).

    Но такой метод умножения чисел очень простой, к тому же он нерационален. Допустим, что у пользователя есть таблица с 2 колонками и перед ним стоит задача перемножить их. Можно, конечно, прописывать все вручную, но это займет слишком много времени. А еще и значения могут периодически меняться, и придется постоянно редактировать формулы. В общем, всего этого можно не делать, поскольку Эксель умеет выполнять операции с цифрами и другим способом. Например, умножая значения в ячейках.

    Видео по операциям умножения в Excel

    Как умножить ячейки в Excel?

    Для начала нужно заполнить 2 любых поля данными. Например, в поле A1 можно ввести цифру 10, а в поле B1 — 5. После этого надо выполнить следующие действия:

    • выделить поле C1 и ввести знак равенства;
    • щелкнуть левой кнопкой мыши на ячейке A1 и написать звездочку;
    • щелкнуть мышкой на ячейке B1 и нажать Enter.

    Два примера формул, при помощи которых можно перемножить значения двух ячеек Excel

    После этого в клеточке C1 будет отображено число 50. Если щелкнуть на ячейке C1 и посмотреть на строку формул, то можно увидеть следующее: =A1*B1. Это означает, что теперь Excel умножает не конкретные цифры, а значения в этих полях. Если их изменить, результат тоже изменится. Например, в поле A1 можно написать цифру 3, и в поле C1 тут же отобразится результат — 15. Такой способ умножения чисел является классическим. Как правило, вручную цифры никто не прописывает, всегда умножают ячейки

    Есть еще одна небольшая хитрость — копирование формул. В качестве примера можно взять небольшую таблицу (5 строк и 2 столбца). Цель — перемножить значения в каждой строке (т.е. A1 умножить на B1, A2 на B2, …, A5 на B5). Для того чтобы не писать одну и ту же формулу каждый раз, достаточно написать ее только для первой строки, а затем выделить клеточку с результатом (С1) и потянуть вниз за маленький черный квадратик, который находится в правом нижнем углу. Формула «потянется» вниз, и результат будет посчитан для всех строк.

    Вот таким несложным способом можно умножить в Excel и цифры, и ячейки. Кроме того, этот же принцип действует и для остальных математических операторов (сложение, вычитание, деление). В таких ситуациях нужно всего лишь указать другой арифметический знак, а все операции с цифрами (или полями) осуществляются точно так же.

    Отблагодари меня, поделись ссылкой с друзьями в социальных сетях:

    Функция СУММПРОИЗВ() — Сложение и подсчет с множественными условиями в MS EXCEL

    Функция СУММПРОИЗВ() , английская версия SUMPRODUCT(), не так проста, как кажется с первого взгляда: помимо собственно нахождения суммы произведений, эта функция может использоваться для подсчета и суммирования значений на основе критериев, а также, в некоторых случаях, избавить от необходимости применений формул массива.

    Существует несколько вариантов применения функции СУММПРОИЗВ() :

    • нахождение суммы произведений элементов списка (массива);
    • суммирование и подсчет значений, удовлетворяющих определенным критериям;
    • замена формул массива (в некоторых случаях).

    Нахождение суммы произведений элементов массивов

    В этом разделе показан синтаксис функции СУММПРОИЗВ() и раскрыт ее потенциал для других применений.

    Пусть имеется 2 диапазона чисел A3:A6 и B3:B6, содержащие соответственно 2 массива чисел: <4:8:6:1>и <7:6:7:5>. Записав формулу =СУММПРОИЗВ(A3:A6;B3:B6) , получим 123. Результат получен поэлементным перемножением всех элементов двух массивов, а затем сложением полученных произведений. То есть были выполнены следующие арифметические действия: 4*7 + 8*6 + 6*7 + 1*5= 123

    Таким образом, можно найти сумму произведений 3-х, 4-х и т.д. массивов.

    Аргументы, которые являются массивами, должны иметь одинаковые размерности (в нашем случае это массивы по 4 элемента). В противном случае функция СУММПРОИЗВ() возвращает значение ошибки #ЗНАЧ!.

    В формуле =СУММПРОИЗВ(A3:A6;B3:B6) функция СУММПРОИЗВ() трактует нечисловые элементы массивов как нулевые. Однако, как показано ниже, функцию можно использовать для подсчета текстовых значений.

    Что произойдет если указать только 1 массив, т.е. =СУММПРОИЗВ(A3:A6) ? Тогда функция СУММПРОИЗВ() вернет сумму элементов, т.е. будет эквивалентна функции СУММ() : =СУММ(A3:A6) .

    Синтаксис функции СУММПРОИЗВ() позволяет не просто указывать в качестве аргумента определенный диапазон, но и осуществлять арифметические действия перед операцией суммирования. Например, записав:

    • =СУММПРОИЗВ(A3:A6*2) , получим сумму произведений =38 (каждый элемент массива из A3:A6 был умножен на 2, затем все произведения просуммированы);
    • =СУММПРОИЗВ(A3:A6*B3:B6) , получим результат суммы произведений – 123 (все элементы массивов были попарно перемножены, а затем сложены, т.е. A3*B3+ A4*B4+ A5*B5+ A6*B6), т.е. эта запись эквивалента формула =СУММПРОИЗВ(A3:A6;B3:B6) ;
    • =СУММПРОИЗВ(A3:A6+B3:B6) , получим сумму элементов из двух диапазонов;
    • =СУММПРОИЗВ(A3:A6/B3:B6 ), получим сумму попарных отношений всех элементов, т.е. 4/7 + 8/6 + 6/7 + 1/5= 2,9619

    Аналогичные вычисления можно выполнить и с функцией СУММ() , только для этого нужно ее ввести как формулу массива, т.е. после ввода функции в ячейку вместо ENTER нажать CTRL+SHIFT+ENTER: =СУММ(A3:A6/B3:B6)

    Читать еще:  Функция сжпробелы в excel

    Прелесть функции СУММПРОИЗВ() в том, что после ввода функции в ячейку можно просто нажать ENTER, что снимает некий психологический барьер перед использованием формул массива.

    Оказывается, что в качестве аргумента этой функции можно указать не только произведение массивов ( A3:A6*B3:B6 ), но и использовать другие функции и даже применить к массивам операции сравнения, т.е. использовать ее для сложения чисел, удовлетворяющих определенным условиям.

    Суммирование и подсчет значений удовлетворяющих определенным критериям

    Попробуем подсчитать число значений больших 2 в диапазоне A3:A6, содержащий значения 4, 8, 6, 1.

    Если мы запишем формулу =СУММПРОИЗВ(A3:A6>2) , то получим результат 0. Выделив в Строке формул A3:A6>2 и нажав клавишу F9, получим массив <ИСТИНА: ИСТИНА: ИСТИНА: ЛОЖЬ>, который говорит, что мы движемся в правильном направлении: в диапазоне A3:A6 больше 2 только первые 3 значения. Хотя значению ИСТИНА соответствует 1, а ЛОЖЬ – 0, мы не получим 3, т.к. для перевода значений ИСТИНА/ЛОЖЬ в числовую форму требуется применить к ним арифметическую операцию. Для этого можно, например, применить операцию двойного отрицания (—), что позволит привести массив в числовую форму <1:1:1:0>.

    Итак, задача подсчета значений больше 2 решается следующим образом: =СУММПРОИЗВ(—(A3:A6>2))

    Вместо двойного отрицания можно использовать другие формулы: =СУММПРОИЗВ(1*(A3:A6>2)) или =СУММПРОИЗВ(0+(A3:A6>2)) или даже так =СУММПРОИЗВ((A3:A6>2)^1) .

    Запись >2 является критерием, причем можно указать любые операции сравнения ( =; =).

    Критерии можно указывать в форме ссылки: =СУММПРОИЗВ(—(A3:A6>G8)) – ячейка G8 должна содержать число 2.

    Критерии можно применять и к текстовым значениям, например, =СУММПРОИЗВ(—(B3:B6=»яблоки»)) – вернет количество ячеек, содержащие слово яблоки (подробнее, например, в статье Подсчет значений с множественными критериями (Часть 1. Условие И)).

    Функцию СУММПРОИЗВ() можно использовать для отбора значений по нескольким критериям (с множественными условиями). Как известно, 2 критерия могут образовывать разные условия:

    • Условие ИЛИ. Например, подсчитать ячеек содержащих значение яблоки ИЛИ груши =СУММПРОИЗВ((B3:B6=»яблоки»)+ (B3:B6=»груши») ) ;
    • Условие И. Например, подсчитать количество значений больше 2 и меньше 5: =СУММПРОИЗВ((A3:A6>2)* (A3:A6 2)* (A3:A6 СРЗНАЧ(A3:A6))*(A3:A6)) сумма значений, которые больше среднего.

    Как не забивать гвозди микроскопом с функцией СУММПРОИЗВ

    Стандартное использование

    Базовый синтаксис нашей функции прост:

    =СУММПРОИЗВ( Массив1 ; Массив2 ; . )

    Самый скучный вариант использования этой замечательной функции — применять ее так, как описано в справке — для суммирования попарных произведений ячеек в двух (и более) указанных диапазонах. Например, можно без дополнительного столбца расчитать общую стоимость заказа:

    По сути, то, что делает эта функция можно выразить формулой:

    = B2*C2 + B3*C3 + B4*C4 + B5*C5

    Технически, перемножаемых массивов (диапазонов) может быть не два, а три или больше (до 255). Главное, чтобы они были одного размера. Удобно, но ничего особенно. Однако, использовать СУММПРОИЗВ только так — забивать гвозди микроскопом, ибо, на самом деле, она умеет гораздо больше.

    Работа с массивами без Ctrl+Shift+Enter

    Если вы хоть немного знакомы в Excel с формулами массива, то должны понимать их мощь и красоту. Иногда одна формула массива может заменить несколько столбцов дополнительных вычислений и ручного труда. Но у формул массива есть и минусы. Главные — это относительная сложность понимания, замедление пересчета книги и необходимость вводить эти формулы сочетанием Ctrl+Shift+Enter вместо обычного Enter. И вот как раз с последним может помочь наша функция СУММПРОИЗВ. Нюанс в том, что она умеет работать с массивами по определению, т.е. не требует обязательного нажатия Ctrl+Shift+Enter при вводе.

    На этом факте основано большинство трюков с использованием СУММПРОИЗВ (SUMPRODUCT) . Давайте, для примера, рассмотрим пару-тройку наиболее характерных сценариев.

    Подсчет количества выполненных условий

    Допустим, нам нужно посчитать количество филиалов компании, где план выполнен (т.е. факт больше или равен плану). Это можно сделать одной формулой с СУММПРОИЗВ без дополнительных столбцов:

    Умножение на 1, в данном случае, нужно, чтобы преобразовать результаты сравнения плана и факта — логическую ИСТИНУ и ЛОЖЬ в 1 и 0, соответственно.

    Проверка нескольких условий

    Если нужно проверять больше одного условия, то формулу из предыдущего примера нужно будет дополнить еще одним (или несколькими) множителями. И если нужно подсчитывать не количество, а сумму, то умножать можно не на 1, а на диапазон с суммируемыми данными:

    Фактически, получается что-то весьма похожее на математическую функцию выборочного подсчета СУММЕСЛИМН (SUMIFS) , которая также умеет проверять несколько условий (до 127) и суммировать по ним значения из заданного диапазона.

    Логические связки И и ИЛИ (AND и OR)

    Если нужно связывать условия не логическим «И», как в примере выше (Факт>=План) И (Регион=Восток) , а логическим ИЛИ, то конструкция немного изменится — знак умножения заменяется на плюс:

    Подсчет по данным из закрытого(!) файла

    Кроме всего вышеперечисленного, у СУММПРОИЗВ есть еще одно неочевидное и весьма полезное свойство — она умеет работать с данными из неоткрытых книг. Если, для сравнения, попробовать подсчитать в другом файле количество филиалов из региона Восток нашей книги и написать вот такое:

    . то вторая формула с классической функцией СЧЁТЕСЛИМН (COUNTIFS) будет работать только до тех пор, пока исходный файл открыт. Если его закрыть, то появляется ошибка #ЗНАЧ! Наша же функция СУММПРОИЗВ (SUMPRODUCT) спокойно считает по данным даже из неоткрытой книги!

    Похожие статьи

    Ссылка на основную публикацию
    Похожие публикации
    Adblock
    detector