Как написать формулу в excel если то несколько условий примеры

Примеры нескольких условий в формуле «если» в excel

Основу любого логического выражения составляют две величины: истина (TRUE) и ложь (FALSE). С помощью логических выражений строятся многочисленные деревья решений. Самое простое – вопрос с ответом «ДА» или «НЕТ». В случае «ДА» выполняется одно действие, в случае «НЕТ» – другое. Для реализации условий существует программный оператор IF (ЕСЛИ).

В программе EXCEL есть функция IF, которая позволяет сделать самые невероятные логические конструкции, вкладывая операторы IF друг в друга. В старых версиях программы вложенность была ограничена 7 уровнями, ЕСЛИ в EXCEL 2010 не имеет ограничений, а в версии 2016 появилась новая функция ЕСЛИМН, учитывающая множественность вложений.

Познакомимся с многоликой функцией IF.

Функция IF

ЕСЛИ – стандартная функция программы EXCEL, которая выполняет проверку конкретного условия. Условие представляет собой вопрос, имеющий два ответа: истина и ложь.

Условие записывается в виде логического выражения, состоящего из правой и левой части, связанного логическими операторами сравнения: больше (>), меньше ( ), а также >= и =10); 1;0)

Эта формула выделит в общем списке нужную категорию работников по установленному качественному признаку =1.

Функция IF с формулой ИЛИ

Вариант использования функции ИЛИ с IF может быть следующий. Руководство предприятия в течение года поквартально поощряло работников. Необходимо выбрать всех, кто получал поквартальные премии больше 5000 р.

Конструкция ИЛИ имеет синтаксис аналогичный формуле И. Но ИСТИНА возвращается при условии истинности хотя бы одного логического выражения.

В нашем примере необходима формула:

=ЕСЛИ(ИЛИ(ячейка_премия1квартал>=5000; ячейка_премия2квартал>=5000; ячейка_премия3квартал>=5000; ячейка_премия4квартал>=5000);1;0)

Последующая фильтрация данных по признаку 1 даст сделать нужный список трудящихся.

Таким образом, очевидна полезность функции IF. В новых версиях программы появляются улучшенные формулы, объединяющие наиболее востребованные старые приёмы и действия, что даёт неограниченные возможности для изучения и применения на практике программы эксель.

Примеры использования условий в формулах Excel

Здравствуйте, друзья! Часто ли вам приходится делать выбор? Например, захотели купить новый телефон, а полной суммы денег у вас нет. Взять кредит или копить? Так сегодня разберем как делать выбор в электронных таблицах Excel. Это позволяет сделать условная функция ЕСЛИ().

Условная функция ЕСЛИ()

В этой функции проверяется истинность одного или нескольких логических выражений и выбирается дальнейшее действие. В логических выражениях используют знаки операций отношения между сравниваемыми величинами.

Простое условие

Что же делает функция ЕСЛИ()? Посмотрите на схему. Здесь приведен простой пример работы функции при определении знака числа а.

Блок-схема «Простое условие». Определение отрицательных и неотрицательных чисел

Условие а>=0 определяет два возможных варианта: неотрицательное число (ноль или положительное) и отрицательное. Ниже схемы приведена запись формулы в Excel. После условия через точку с запятой перечисляются варианты действий. В случае истинности условия, в ячейке отобразится текст «неотрицательное», иначе — «отрицательное». То есть запись, соответствующая ветви схемы «Да», а следом – «Нет».

Текстовые данные в формуле заключаются в кавычки, а формулы и числа записывают без них.

Если результатом должны быть данные, полученные в результате вычислений, то смотрим следующий пример. Выполним увеличение неотрицательного числа на 10, а отрицательное оставим без изменений.

Блок-схема «Простое условие». Расчет данных

На схеме видно, что при выполнении условия число увеличивается на десять, и в формуле Excel записывается расчетное выражение А1+10 (выделено зеленым цветом). В противном случае число не меняется, и здесь расчетное выражение состоит только из обозначения самого числа А1 (выделено красным цветом).

Это была краткая вводная часть для начинающих, которые только начали постигать азы Excel. А теперь давайте рассмотрим более серьезный пример с использованием условной функции.

Задание:
Процентная ставка прогрессивного налога зависит от дохода. Если доход предприятия больше определенной суммы, то ставка налога выше. Используя функцию ЕСЛИ, рассчитайте сумму налога.

Решение:

Решение данной задачи видно на рисунке ниже. Но внесем все-таки ясность в эту иллюстрацию. Основные исходные данные для решения этой задачи находятся в столбцах А и В. В ячейке А5 указано пограничное значение дохода при котором изменяется ставка налогообложения. Соответствующие ставки указаны в ячейках В5 и В6. Доход фирм указан в диапазоне ячеек В9:В14. Формула расчета налога записывается в ячейку С9: =ЕСЛИ(B9>A$5;B9*B$6;B9*B$5). Эту формулу нужно скопировать в нижние ячейки (выделено желтым цветом).

В расчетной формуле адреса ячеек записаны в виде A$5, B$6, B$5. Знак доллара делает фиксированной часть адреса, перед которой он установлен, при копировании формулы. Здесь установлен запрет на изменение номера строки в адресе ячейки.

Составное условие

Составное условие состоит из простых, связанных логическими операциями И() и ИЛИ().

И() — логическая операция, требующая одновременного выполнения всех условий, связанных ею.
ИЛИ() — логическая операция, требующая выполнения любого из перечисленных условий, связанных ею.

Логическая операция И()

Например: Рассмотрим электронную таблицу «Ведомость сдачи вступительных экзаменов». Для зачисления абитуриента в ВУЗ, ему необходимо преодолеть проходной балл, и по математике отметка должна быть выше 70 баллов.
Посмотрите внимательно на рисунок ниже.

В этом примере функция ЕСЛИ() использует составное условие, связанное логической операцией И(). Обратите внимание: абитуриент Петров не зачислен, хотя сумма его баллов равна проходному.

Почему так произошло? Посмотрим внимательно на условие в нашей формуле =ЕСЛИ(И(E6>=D2;B6>70);»зачислен»;»не зачислен»). Логическая операция И() требует выполнения всех условий, но у нас выполняется только одно. Второе условие B6>70 не выполнено, поэтому составное условие принимает значение «ложь». И на экран выводится сообщение «не зачислен» (вспоминаем схему – ветвь «нет»).

Задание:
В торговой фирме перед Новым Годом устроена праздничная распродажа. Рассчитать сумму продаж с учетом скидки, назначаемой в период распродажи.

1. Рассчитайте общую стоимость продаж. Итого = Стоимость* Количество.

2. Определите скидку (в процентах), используя функцию ЕСЛИ(). Если дата продажи попадает в период праздничной распродажи, то назначается скидка, иначе скидка равняется нулю. При задании условий используйте логическую функцию И().

3. Определите сумму продажи с учетом скидки. Сумма продажи с учетом скидки = Итого* (1- Скидка%).

Решение:

Для проведения расчетов необходимо вписать следующие формулы:

  • В ячейке Е7: =B7*C7
  • В ячейке F7: =ЕСЛИ(И(D7>=D$4;D7

Абитуриент Сидоров зачислен, хотя не набрал проходной балл. Вот формула =ЕСЛИ(ИЛИ(B7>60;E7>D2;);»зачислен»;»не зачислен»). Здесь использована операция ИЛИ(), поэтому достаточно выполнение хотя бы одного условия. Что и произошло, первое условие B7>60 истинно. Оно привело к выводу сообщения о зачислении абитуриента.

Задание:
В торговой фирме установлены дни распродаж — последние числа месяца. Рассчитать сумму продаж с учетом скидки, назначаемой в дни распродажи.

1. Рассчитайте общую стоимость продаж. Итого = Стоимость* Количество.

2. Определите скидку (в процентах), используя функцию ЕСЛИ(). Если дата продажи совпадает с датами распродаж, то назначается скидка, иначе скидка равняется нулю. При задании условий используйте логическую функцию ИЛИ().

3. Определите сумму продажи с учетом скидки. Сумма продажи с учетом скидки = Итого* (1- Скидка%)

Решение:

Для проведения расчетов необходимо вписать следующие формулы:

  • В ячейке Е7: =B7*C7
  • В ячейке F7: =ЕСЛИ(ИЛИ(D7=D$4;D7=E$4;D7=F$4);B$4;0)
  • В ячейке G7: =E7*(1-F7)

и скопировать по соответствующим столбцам до 15 строки включительно.

Вложенные условия

Если для решения задачи недостаточно использования составных условий, то тогда применяют более сложную конструкцию вложенных условий. Смотрите схему.

В данном примере вторая функция ЕСЛИ() является вложенной и записывается на месте действия, которое вызывается при не выполнении условия первой функции. В Excel последних версий допускается делать до 64 вложений.

Задание:
С целью уменьшения текучести кадров администрация решила выплачивать надбавку за непрерывный стаж работы на своем предприятии. Рассчитайте надбавку за непрерывный стаж работы в соответствии с таблицей Надбавка.

1. Определите стаж работы сотрудников. Стаж = 2018- Год приема на работу.

2. Используя вложенные функции Если, рассчитайте надбавку для сотрудников. Надбавка (руб.) = Надбавка(%)* Оклад

Решение:

Для проведения расчетов необходимо вписать следующие формулы:

  • В ячейке D9: =2018-B9
  • В ячейке E9: =ЕСЛИ(D9>=B$6;C9*C$6;ЕСЛИ(D9>=B$5;C9*C$5;0))

и скопировать по соответствующим столбцам до 19 строки включительно.

В этой статье я постарался максимально подробно и доходчиво объяснить применение условной функции в Excel. Конечно же, в Excel есть и другие функции с условием, но о них поговорим в следующей статье. Друзья, если вам была интересна и полезна данная информация, не забывайте делиться ею в социальных сетях. А также буду рад прочитать ваши комментарии.

Дополнительная информация:

PS: Удивительные факты

Функции Excel ЕСЛИ (IF) и ЕСЛИМН (IFS) для нескольких условий

Логическая функция ЕСЛИ в Экселе – одна из самых востребованных. Она возвращает результат (значение или другую формулу) в зависимости от условия.

Функция ЕСЛИ в Excel

Функция имеет следующий синтаксис.

ЕСЛИ(лог_выражение; значение_если_истина; [значение_если_ложь])

лог_выражение – это проверяемое условие. Например, A2 30) не выполняется и возвращается альтернативное значение, указанное в третьем поле. В этом вся суть функции ЕСЛИ. Протягивая расчет вниз, получаем результат по каждому товару.

Однако это был демонстрационный пример. Чаще формулу Эксель ЕСЛИ используют для более сложных проверок. Допустим, есть средненедельные продажи товаров и их остатки на текущий момент. Закупщику нужно сделать прогноз остатков через 2 недели. Для этого нужно от текущих запасов отнять удвоенные средненедельные продажи.

Пока все логично, но смущают минусы. Разве бывают отрицательные остатки? Нет, конечно. Запасы не могут быть ниже нуля. Чтобы прогноз был корректным, нужно отрицательные значения заменить нулями. Здесь отлично поможет формула ЕСЛИ. Она будет проверять полученное по прогнозу значение и если оно окажется меньше нуля, то принудительно выдаст ответ 0, в противном случае — результат расчета, т.е. некоторое положительное число. В общем, та же логика, только вместо значений используем формулу в качестве условия.

В прогнозе запасов больше нет отрицательных значений, что в целом очень неплохо.

Формулы Excel ЕСЛИ также активно используют в формулах массивов. Здесь мы не будем далеко углубляться. Заинтересованным рекомендую прочитать статью о том, как рассчитать максимальное и минимальное значение по условию. Правда, расчет в той статье более не актуален, т.к. в Excel 2016 появились функции МИНЕСЛИ и МАКСЕСЛИ. Но для примера очень полезно ознакомиться – пригодится в другой ситуации.

Формула ЕСЛИ в Excel – примеры нескольких условий

Довольно часто количество возможных условий не 2 (проверяемое и альтернативное), а 3, 4 и более. В этом случае также можно использовать функцию ЕСЛИ, но теперь ее придется вкладывать друг в друга, указывая все условия по очереди. Рассмотрим следующий пример.

Нескольким менеджерам по продажам нужно начислить премию в зависимости от выполнения плана продаж. Система мотивации следующая. Если план выполнен менее, чем на 90%, то премия не полагается, если от 90% до 95% — премия 10%, от 95% до 100% — премия 20% и если план перевыполнен, то 30%. Как видно здесь 4 варианта. Чтобы их указать в одной формуле потребуется следующая логическая структура. Если выполняется первое условие, то наступает первый вариант, в противном случае, если выполняется второе условие, то наступает второй вариант, в противном случае если… и т.д. Количество условий может быть довольно большим. В конце формулы указывается последний альтернативный вариант, для которого не выполняется ни одно из перечисленных ранее условий (как третье поле в обычной формуле ЕСЛИ). В итоге формула имеет следующий вид.

Комбинация функций ЕСЛИ работает так, что при выполнении какого-либо указанно условия следующие уже не проверяются. Поэтому важно их указать в правильной последовательности. Если бы мы начали проверку с B2 =1. Однако этого можно избежать, если в поле с условием написать ИСТИНА, указывая тем самым, что, если не выполняются ранее перечисленные условия, наступает ИСТИНА и возвращается последнее альтернативное значение.

Теперь вы знаете, как пользоваться функцией ЕСЛИ в Excel, а также ее более современным вариантом для множества условий ЕСЛИМН.

Формула в эксель если несколько условий

Функции программы Microsoft Excel: оператор «ЕСЛИ»

​Смотрите также​ функция СЧЕТЕСЛИМН.​ знаки, ставим перед​ =3%​=СУММЕСЛИ(A2:A5;»>160000″;B2:B5)​можно использовать подстановочные​СУММЕСЛИ​ статьи «Выбрать сразу​Нам нужно, чтобы​ таких-то ячеек, т.д.​Если значение в ячейке​Определяет, выполняется ли следующее​ других вычислений или​ а если ложно,​

​ другом случае —​ из нескольких условий.​

Общее определение и задачи

​ то выводимый результат​Среди многих функций, с​Когда в качестве критерия​ ними знак тильды​от 6-10=6%​Сумма комиссионных за имущество​ знаки: вопросительный знак​используется, если необходимо​ много данных из​ в ячейке B​ Все это пишем​ A2 равно 15,​ условие: значение в​

​ значений, отличных от​ то «Плохо».​ «меньше или равно​Итак, предположим, что премия​ зависит уже от​

Пример использования

​ которыми работает программа​ указывается ссылка на​ (

​ стоимостью больше 1​ (​ просуммировать значения диапазона,​ таблицы Excel» здесь.​ 4 было написано​ в формуле. Функция​ возвращается «ОК», в​ ячейке A5 не​ ИСТИНА или ЛОЖЬ​Скопировав формулу в остальные​ 25».​ к 8 марта​ второго оператора.​ Microsoft Excel, следует​ диапазон ячеек с​Для нормального функционирования формулы​от 16-20=18%​ 600 000 ₽.​?​ соответствующие указанному условию.​ Этой формулой выбираем​ «100», если в​ в Excel «ЕСЛИ»​ противном случае —​

​ равняется строке «Винты»​Для выполнения этой задачи​ ячейки таблицы, можно​Функция​ в 100 рублей​

​Для примера возьмем все​ выделить функцию «ЕСЛИ».​ условиями, функция возвращает​ в ячейках с​от 20-25=23%​630 000 ₽​) и звездочку (​ Предположим, например, что​ из таблицы товара​ ячейке A 4​ пригодится в таблицах,​

​ «Неверно» (ОК).​ (ЛОЖЬ).​ используются функции​ увидеть, что на​

Пример функции с несколькими условиями

​ЕСЛИ​ положена только женщинам,​ ту же таблицу​ Это один из​ массив. Для ввода​ текстовыми значениями не​от 25и выше=33%​=СУММЕСЛИ(A2:A5; «>160000»)​*​ в столбце с​ и переносим в​ будет стоять слово​ чтобы посчитать определенные​

​=ЕСЛИ(A2<>15; «ОК»; «Неверно»)​=ИЛИ(A5<>«Винты»;A6 = «Шурупы»)​И​ отлично сдал один​является очень гибкой​ которые входят в​ с выплатами премии​ тех операторов, к​ формулы нужно выделить​ должно пробелов или​Все эти условия​Сумма по имуществу стоимостью​). Вопросительный знак соответствует​ числами необходимо просуммировать​ лист заказа выбранные​ «Да». В ячейке​ данные, в анкетах,​Если значение в ячейке​

​Определяет, выполняется ли следующее​,​ человек, а на​ и ее можно​ число основного персонала.​ к 8 марту.​ которым пользователи прибегают​ такое количество ячеек,​ непечатаемых знаков.​ должны быть в​ больше 1 600 000​ одному любому символу,​ только значения, превышающие​ покупателем позиции.​ В4 написали такую​ в тестах, т.д.​ A2 не равно​ условие: значение в​ИЛИ​ оценки хорошо и​ применять в различных​

​ В этом случае,​ Но, на этот​ чаще всего, при​ как в диапазоне​

​​ одной ячейке да​ ₽.​

Пример с выполнением двух условий одновременно

​ а звездочка — любой​ 5. Для этого​Ещё есть функция​ формулу.​Функция Excel «ЕСЛИ»​ 15, возвращается «ОК»,​

​ ячейке A5 не​и​ плохо по два​ ситуациях. Рассмотрим еще​ если работник мужчина,​ раз, согласно условиям,​ выполнении задач в​ с критериями. После​Посчитаем числовые значения в​ каждой строки столбца.​9 000 000 ₽​ последовательности символов. Если​ можно использовать следующую​ «СЧЁТЕСЛИ» в Excel​=ЕСЛИ(A4=»Да»;100;»»)​находится на закладке​ в противном случае​ равняется строке «Винты»​НЕ​ человека.​ один пример. В​ или относится к​ размер премии зависит​ приложении. Давайте разберемся,​ введения аргументов нажать​ одном диапазоне. Условие​ ПОМОГИТЕ пожалуйста. Никак​

​=СУММЕСЛИ(A2:A5;300000;B2:B5)​ требуется найти непосредственно​ формулу:​ — она считает​

Пример использования оператора «ИЛИ»

​Обратите внимание!​ «Формулы» в разделе​ — «Неверно» (Неверно).​ или значение в​, а также операторы​Как видите, вместо второго​ таблице ниже приведены​

​ вспомогательному персоналу, то​ от категории работника.​ что представляет собой​ одновременно сочетание клавиш​ подсчета – один​ не соображу как​Сумма комиссионных за имущество​ вопросительный знак (или​=СУММЕСЛИ(B2:B25;»>5″)​ количество ячеек по​В третьем условии​ «Библиотека функций» -​=ЕСЛИ(НЕ(A2​ ячейке A6 равняется​ (см. пример ниже).​ и третьего аргументов​ результаты переаттестации сотрудников​ величина его премии​ Женщины, имеющие статус​ функция «ЕСЛИ», и​

​ критерий.​ написать формулу​ стоимостью 3 000 000​ звездочку), необходимо поставить​Это видео — часть​ нашим условиям. Смотрите​ в формуле мы​ «Логические». Встаем на​Если значение в ячейке​ строке «Шурупы» (ИСТИНА).​Чтобы этот пример проще​ функции​

Функция ЕСЛИ в Excel на простом примере

​ будет равна нулю,​​ основного персонала получают​​ как с ней​ + Enter. Excel​У нас есть такая​Алексей матевосов (alexm)​ ₽.​ перед ним знак​ учебного курса сложение​ статью «Функция «СЧЁТЕСЛИ​ поставили не «нуль»,​ ячейку В1, вызываем​ A2 не меньше​Дополнительные сведения об использовании​ было понять, скопируйте​ЕСЛИ​В столбец C нам​​ а иначе –​​ по 1000 рублей​

Коротко о синтаксисе

​ работать.​​ распознает формулу массива.​​ таблица:​: Значение стажа в​

​210 000 ₽​

​ «тильда» (​ чисел в Excel.​ в Excel». Эту​ а две двойные​ функцию «ЕСЛИ».​ и не равно​ этих функций см.​ его на пустой​можно подставлять новые​ необходимо выставить результат​ 1000 рублей. В​ премии, а вспомогательный​Скачать последнюю версию​

​СЧЕТЕСЛИ с двумя условиями​Посчитаем количество ячеек с​ ячейке А1​=СУММЕСЛИ(A2:A5;»>» &C2;B2:B5)​

​Советы:​ функция может посчитать​ кавычки – это​

​Первый пример.​ 15, возвращается «ОК»,​ в разделах Функция​ лист.​​ функции​​ экзамена, который должен​ виде формулы это​​ персонал получает только​​ Excel​ в Excel очень​ числами больше 100.​Формула с ЕСЛИ​Сумма комиссионных за имущество,​).​ ​

​ ячейки, в которых​​ значит «Пусто» (оставить​​Нам нужно выбрать​ в противном случае​ И, Функция ИЛИ​Копирование примера​ЕСЛИ​ содержать всего два​ выглядит так: «=ЕСЛИ(ИЛИ(B6=»муж.»;​ 500 рублей. Естественно,​

​«ЕСЛИ» является стандартной функцией​ часто используется для​ Формула: =СЧЁТЕСЛИ(B1:B11;»>100″). Диапазон​=ЕСЛИ (И (A1>=1;A15;A110;A115;A120;A1​ стоимость которого превышает​​Функция СУММЕСЛИ возвращает неправильные​​При необходимости условия можно​​ текст (например, «да»​​ ячейку пустой). Скопировали​ из столбца А​ — «Неверно» (Неверно).​ и Функция НЕ.​

  1. ​Выделите пример, приведенный в​, тем самым расширяя​ варианта:​ C6=»Вспомогательный персонал»); «0»;​
  2. ​ что мужчинам этот​​ программы Microsoft Excel.​​ автоматизированной и эффективной​​ – В1:В11. Критерий​​ Формула без ЕСЛИ​
  3. ​ значение в ячейке​ результаты, если она​ применить к одному​ — в анкете).​ формулу в ячейку​ числа «2» и​=ЕСЛИ(A5<>«Винты»; «ОК»; «Неверно»)​
  4. ​К началу страницы​ этой статье.​ число условий, которое​Сдал​ «1000»)». Записываем эту​

Функция ЕСЛИ и несколько условий

​ вид выплат вообще​​ В её задачи​​ работы с данными.​ подсчета – «>100».​=(A1>=1)*(A1<>5)*(A1<>10)*(A1<>15)*(A1<>20)*(A1<>25)*33​ C2.​ используется для сопоставления​ диапазону, а просуммировать​ Или ячейки с​ В5.​ написать в столбце​Если значение в ячейке​Для выполнения этой задачи​​Важно:​​ формула может обработать.​или​ формулу в соответствующую​​ не положен независимо​​ входит проверка выполнения​ Поэтому продвинутому пользователю​​ Результат:​​Формула с ВЫБОР​

    ​490 000 ₽​ строк длиннее 255 символов​ соответствующие значения из​​ числом или числами​​Третий пример.​​ В то значение,​​ A5 не равно​

  • ​ используются функции​ Не выделяйте заголовки строк​ Таким образом, Вы​​Не сдал​​ ячейку таблицы.​ от категории.​ конкретного условия. В​ настоятельно рекомендуется внимательно​Если условие подсчета внести​=ВЫБОР (ЕСЛИ (ОКРВВЕРХ​Скопируйте образец данных из​​ или применяется к​​ другого диапазона. Например,​​ больше, например, 5.​​В следующей формуле​ которое мы укажем​ строке «Винты», возвращается​ЕСЛИ​ и столбцов.​
  • ​ можете создать нужное​. Те, кто набрал​«Протягиваем» результаты вниз.​Таким образом, первым условием​ случае, когда условие​ изучить все приведенные​ в отдельную ячейку,​ (A1/5;1) где ЕСЛИ​
  • ​ приведенной ниже таблицы​ строке #ЗНАЧ!.​ формула​​ Не только посчитать​​ поставили в третьем​ в формуле. Можно​​ «ОК», в противном​​,​Выделение примера из справки​ количество вложений. Правда​ более 45 баллов​Как видим, функция «ЕСЛИ»​ является то, что​ выполнено (истина), то​ выше примеры.​ можно в качестве​ (ОКРВВЕРХ (A1/5;1)​ и вставьте его​Аргумент​=СУММЕСЛИ(B2:B5; «Иван»; C2:C5)​

    ​ ячейки, но и​ условии знак «Тире».​ выбрать любые числа,​ случае — «Неверно»​​И​​Нажмите клавиши CTRL+C.​​ есть очевидный недостаток​​ – сдали экзамен,​

    ​ может оказаться для​ если сотрудник мужчина,​ в ячейку, где​​Посчитаем количество реализованных товаров​​ критерия использовать ссылку:​Loony​ в ячейку A1​диапазон_суммирования​суммирует только те​ вычислить процент определенных​​ =ЕСЛИ(A5=»Да»;100;»-«)​​ слова, т.д.​ (Неверно).​и​Создайте пустые книгу или​ такой конструкции, после​ остальные нет.​ пользователя хорошим помощником​

    ​ то величина получаемой​

    Создание условных формул

    ​ использована данная функция,​ по группам.​Посчитаем текстовые значения в​: ЕСЛИ (. ЕСЛИ. (ЕСЛИ. ))​ нового листа Excel.​может не совпадать​​ значения из диапазона​​ ответов к общему​​В ячейку В6​​Появившееся диалоговое окно​​=ЕСЛИ(И(A2>A3; A2​​ИЛИ​​ лист в Excel.​​ 3-5 вложений формула​

    ​Выделите ячейку, в которую​​ при работе с​​ премии равна нулю.​ возвращается одно значение,​

    ​Сначала отсортируем таблицу так,​

    ​ одном диапазоне. Условие​ ) и так​

    ​ Чтобы отобразить результаты​ по размерам с​

    ​ C2:C5, для которых​ числу ответов.​

    ​ написали такую формулу.​ заполнили так.​Если значение в ячейке​, а также операторы​

    В этой статье

    ​На листе выделите ячейку​ станет нечитаемой и​ необходимо ввести формулу.​ данными в программе​

    ​ Если же данное​ а если не​ чтобы одинаковые значения​ поиска – один​ далее — вложенные​

    Создание условной формулы с результатом, являющимся логическим значением (ИСТИНА или ЛОЖЬ)

    ​ формул, выделите их​ аргументом​​ соответствующие значения из​​Есть ещё функция​​ =ЕСЛИ(A6=»%»;1;»нет») Здесь в​​В формуле «ЕСЛИ» нужно​​ A2 больше значения​​ (см. пример ниже).​ A1 и нажмите​

    ​ громоздкой, и с​ В нашем случае​ Microsoft Excel. Она​ значение ложно, и​

    ​ оказались рядом.​ критерий.​

    ​ операторы.​​ и нажмите клавишу​диапазон​

    ​ диапазона B2:B5 равны​

    ​ в Excel «СУММЕСЛИ».​

    ​ третьем условии написали​ написать три условия.​

    ​ в ячейке A3​Чтобы этот пример проще​ клавиши CTRL+V.​

    ​ ней будет невозможно​​ это ячейка C3.​ позволяет отобразить результаты​ сотрудник не мужчина​ другое.​

    ​Первый аргумент формулы «ПРОМЕЖУТОЧНЫЕ.ИТОГИ»​Формула: =СЧЁТЕСЛИ(A1:A11;»табуреты»). Или:​Stalin​ F2, а затем —​. При определении фактических​ «Иван».​​ Про эту функцию​​ слово «нет» в​​ В формуле эти​​ и меньше значения​​ было понять, скопируйте​​Важно:​

    ​ работать.​Введите в нее выражение:​ соответствующие определенным условиям.​ (т.е. женщина), то​

    Формула в Эксель ЕСЛИ, когда несколько условий

    Эксель — отличный редактор, позволяющий решать множество задач быстро и просто. Здесь легко посчитать проценты, провести корреляционный анализ, построить графики и т.д. Функционал программы огромен, поэтому далеко не все сразу понимают, каким оператором нужно воспользоваться, чтобы справиться с конкретной проблемой. Рассмотрим на примерах, как работать с формулой ЕСЛИ с несколькими условиями.

    Функция ЕСЛИ

    Написать формулу в Excel можно двумя способами — вручную, введя данные в строку функции или прямо в ячейку, и обратившись к меню. Попробуем разобраться, как пользоваться функцией ЕСЛИ на примере. Алгоритм действий довольно простой — указывается определенное условие и варианты, что следует делать в случае истины или лжи (то есть условие либо выполняется, либо нет):

    • Открываем Эксель, найдя программу в меню «Пуск» или на рабочем столе.

    • Вводим данные, с которыми предстоит работать. Допустим, есть информация о сотрудниках компании — ее и будем использовать в качестве материала.

    • Добавляем столбец «Премия» — в него выводим результаты функции ЕСЛИ. Курсор ставим в ячейку G4.

    • Кликаем по значку функции, расположенному слева от строки ввода оператора, которая находится над рабочим полем. Также формулу в Эксель можно вставить, обратившись к пункту меню «Формулы» и выбрав там «Логические».

    • В «Категории» находим «Логические», а в появившемся списке — функцию ЕСЛИ. Кликаем по «Ок».

    • Появится окно, где необходимо указать аргументы функции, то есть условия.

    • Предположим, премия менеджеров составляет 30%. Заполняем аргументы, начиная с логического выражения — пишем там адрес ячейки и нужное значение. В нашем случае это выглядит следующим образом: Лог_выражение = D4=«менеджер». Затем указываем размер премии (30), если выражение истинно, и 0, если оно ложно. Нажимаем «Ок».

    • В результате видим, что премия первого сотрудника составляет 0%, так как он не является менеджером. Условие выполнено!

    • Таблица содержит множество строк, необходимо заполнить их все. Конечно, не требуется каждый раз вбивать функцию заново, ее надо просто скопировать. Сделать это очень просто — кликаем мышкой по ячейке G4 (там уже получен результат), подводим курсор к левому нижнему углу и смотрим, когда он превратится в плюс.

    • Растягиваем формулу на остальные ячейки, держа левую кнопку мыши нажатой и опускаясь вниз.

    Вот и все — менеджеры получают премию. Воспользовавшись формулой ЕСЛИ, можно быстро сделать выборку нужных сотрудников.

    Важно: конечно, посмотрев на пример, кажется, что и вручную несложно совершить подобные действия, однако все зависит от объема информации — чем больше данных в таблице, тем сложнее их анализировать визуально. Риск упустить что-то слишком велик, а Excel не только сэкономит время, но и поможет избежать ошибок.

    Функция ЕСЛИ с условием И

    Часто одним условием дело не ограничивается — например, нужно начислить премию только менеджерам, которые работают в Южном филиале компании. Действуем следующим образом:

    • Выделяем мышкой первую ячейку (G4) в столбце с премиями. Кликаем по значку Fx, находящемуся слева от строки ввода формул.

    • Появится окно с уже заполненными аргументами функции.

    • Изменяем логическое выражение, добавив туда еще одно условие и объединив их с помощью оператора И (условия берем в скобки). В нашем случае получится: Лог_выражение = И(D4=«менеджер»;E4=«Южный»). Нажимаем «Ок».

    • Растягиваем формулу на все ячейки, выделив первую и потянув мышкой вниз при нажатой левой клавише.

    Совет: если в таблице много строк, то становится неудобно постоянно перематывать вверх-вниз, чтобы посмотреть шапку. Выход есть — закрепить строку в Excel. Тогда названия столбцов будут всегда показаны на экране.

    Функция ЕСЛИ с условием ИЛИ

    В качестве примера рассмотрим, как начислить в Экселе премию в размере 40% всем сотрудникам, которые являются бухгалтерами или директорами. То есть произведем выборку по двум условиям:

    • Кликаем мышью по первой ячейке в столбце премий (G4), затем нажимаем на иконку слева от строки ввода формул.

    • Редактируем аргументы функции. Логическое выражение будет представлять собой: ИЛИ(D4=«бухгалтер»;D4=«директор»). В «Значение_если_истина» пишем 40, а в «Значение_если_ложь» — 0. Кликаем «Ок».

    • Копируем формулу, растягивая ее на остальные ячейки. Смотрим результат — премия 40% начислена директору и двум бухгалтерам.

    Функция СУММЕСЛИ

    Данная формула в Экселе применяется, когда требуется суммировать значения в ячейках, попадающих под какое-либо заданное условие. Например, нужно выяснить суммарную заработную плату всех продавцов:

    • Добавляем строку с общей зарплатой продавцов и кликаем по ячейке, куда будет выводится результат.

    • Нажимаем на иконку Fx, которая находится слева от строки ввода функций. В открывшемся окне ищем нужную формулу через поиск — вводим в соответствующее окно «суммесли», выбираем оператор в списке, кликаем «Ок».

    • Появится окно, где необходимо заполнить аргументы функции.

    • Вводим аргументы — первое поле «Диапазон» определяет, какие ячейки нужно проверить. В данном случае — должности работников. Кликаем мышкой в поле «Диапазон» и указываем там D4:D18. Можно поступить еще проще — просто выделить нужные ячейки.

    • В поле «Критерий» вводим «продавец». В «Диапазоне_суммирования» пишем ячейки с зарплатой сотрудников (вручную либо выделив их мышкой). Далее — «Ок».

    • Смотрим на результат — общая заработная плата всех продавцов посчитана.

    Совет: сделать диаграмму в Excel просто и быстро — нужно всего лишь найти соответствующую кнопку на вкладке «Вставка» в меню.

    Функция СУММЕСЛИМН

    Данный оператор в Excel предназначен для вычисления суммы с использованием нескольких условий. К примеру, нужно определить заработную плату менеджеров, работающих в Южном филиале:

    • Добавляем строку с общей зарплатой менеджеров Южного филиала. Выделим ячейку, где будет показываться итог вычислений.

    • Кликаем по значку функции. В появившемся окне в поле поиска вводим «суммеслимн», нажимаем «Найти» и выбираем нужный оператор из списка.

    • В открывшемся окне необходимо заполнить аргументы функции. В «Диапазон_суммирования» указываем ячейки с заработной платой. «Диапазон_условия1» — ячейки с должностями сотрудников. «Условие1» = «менеджер», так как мы суммируем зарплату менеджеров. Теперь нужно учесть второе условие — взять менеджеров из Южного филиала. В «Диапазон_условия2» вводим ячейки с филиалами, «Условие2» = «Южный». Все аргументы определены, нажимаем «Ок».

    • В результате будет рассчитана общая зарплата всех менеджеров, работающих в Южном филиале.

    Функция СЧЁТЕСЛИ

    Данный оператор используется в Экселе, когда нужно посчитать количество ячеек, попадающих под определенное условие. Предположим, требуется узнать, сколько продавцов работает в компании:

    • Добавляем строку с количеством продавцов и выделяем ячейку, куда планируется вывести результат.

    • Кликаем по кнопке «Вставить функцию», расположенной во вкладке «Формулы» в меню. В открывшемся окне в поле «Категория» выбираем «Полный алфавитный перечень». В списке формул находим по алфавиту СЧЁТЕСЛИ, нажимаем «Ок».

    • Заполняем аргументы функции — в поле «Диапазон» указываем ячейки с должностями, в «Критерии» пишем «продавец». Далее — «Ок».

    • В результате получаем количество продавцов, работающих в компании. Эксель просто считает ячейки, где написано «продавец».

    Функция СЧЁТЕСЛИМН

    Иногда возникают более сложные задачи — например, нужно определить, сколько продавцов работает в Северном филиале. Тогда следует воспользоваться формулой СЧЁТЕСЛИМН:

    • Добавляем строку с количеством продавцов Северного филиала и выделяем ячейку с будущим результатом.

    • Кликаем по кнопке «Вставить функцию» во вкладке «Формулы». Через алфавитный перечень находим нужную функцию и нажимаем «Ок».

    • Вводим аргументы функции: «Диапазон_условия1» — это ячейки с должностями, «Условие1» = «продавец». В «Диапазон_условия2» пишем ячейки с филиалами, «Условие2» = «Северный».

    • В итоге будет определено количество продавцов Северного филиала.

    Подводим итоги

    В Excel существует несколько функций категории ЕСЛИ — использовать их нетрудно, так как программа максимально подсказывает алгоритм действий. Формулы существенно облегчают вычисления, на которые без Экселя можно потратить уйму времени и сил. К тому же нивелируется риск ошибок и человеческий фактор. Если возникают сложности с применением операторов, то, скорее всего, дело в неправильном вводе аргументов функции — перепроверьте формулу. Чтобы уточнить синтаксис, лучше воспользоваться справкой, которая в Экселе есть по каждой функции.

    Отблагодарите автора, поделитесь статьей в социальных сетях.

    Похожие статьи

    Читать еще:  Функция расцепить в excel примеры
    Ссылка на основную публикацию
    Похожие публикации
    ×
    ×
    Adblock
    detector