Формула эксель если несколько условий

Примеры нескольких условий в формуле «если» в excel

Основу любого логического выражения составляют две величины: истина (TRUE) и ложь (FALSE). С помощью логических выражений строятся многочисленные деревья решений. Самое простое – вопрос с ответом «ДА» или «НЕТ». В случае «ДА» выполняется одно действие, в случае «НЕТ» – другое. Для реализации условий существует программный оператор IF (ЕСЛИ).

В программе EXCEL есть функция IF, которая позволяет сделать самые невероятные логические конструкции, вкладывая операторы IF друг в друга. В старых версиях программы вложенность была ограничена 7 уровнями, ЕСЛИ в EXCEL 2010 не имеет ограничений, а в версии 2016 появилась новая функция ЕСЛИМН, учитывающая множественность вложений.

Познакомимся с многоликой функцией IF.

Функция IF

ЕСЛИ – стандартная функция программы EXCEL, которая выполняет проверку конкретного условия. Условие представляет собой вопрос, имеющий два ответа: истина и ложь.

Условие записывается в виде логического выражения, состоящего из правой и левой части, связанного логическими операторами сравнения: больше (>), меньше ( ), а также >= и =10); 1;0)

Эта формула выделит в общем списке нужную категорию работников по установленному качественному признаку =1.

Функция IF с формулой ИЛИ

Вариант использования функции ИЛИ с IF может быть следующий. Руководство предприятия в течение года поквартально поощряло работников. Необходимо выбрать всех, кто получал поквартальные премии больше 5000 р.

Конструкция ИЛИ имеет синтаксис аналогичный формуле И. Но ИСТИНА возвращается при условии истинности хотя бы одного логического выражения.

В нашем примере необходима формула:

=ЕСЛИ(ИЛИ(ячейка_премия1квартал>=5000; ячейка_премия2квартал>=5000; ячейка_премия3квартал>=5000; ячейка_премия4квартал>=5000);1;0)

Последующая фильтрация данных по признаку 1 даст сделать нужный список трудящихся.

Таким образом, очевидна полезность функции IF. В новых версиях программы появляются улучшенные формулы, объединяющие наиболее востребованные старые приёмы и действия, что даёт неограниченные возможности для изучения и применения на практике программы эксель.

Формула в эксель если несколько условий

Функции программы Microsoft Excel: оператор «ЕСЛИ»

​Смотрите также​ функция СЧЕТЕСЛИМН.​ знаки, ставим перед​ =3%​=СУММЕСЛИ(A2:A5;»>160000″;B2:B5)​можно использовать подстановочные​СУММЕСЛИ​ статьи «Выбрать сразу​Нам нужно, чтобы​ таких-то ячеек, т.д.​Если значение в ячейке​Определяет, выполняется ли следующее​ других вычислений или​ а если ложно,​

​ другом случае —​ из нескольких условий.​

Общее определение и задачи

​ то выводимый результат​Среди многих функций, с​Когда в качестве критерия​ ними знак тильды​от 6-10=6%​Сумма комиссионных за имущество​ знаки: вопросительный знак​используется, если необходимо​ много данных из​ в ячейке B​ Все это пишем​ A2 равно 15,​ условие: значение в​

​ значений, отличных от​ то «Плохо».​ «меньше или равно​Итак, предположим, что премия​ зависит уже от​

Пример использования

​ которыми работает программа​ указывается ссылка на​ (

​ стоимостью больше 1​ (​ просуммировать значения диапазона,​ таблицы Excel» здесь.​ 4 было написано​ в формуле. Функция​ возвращается «ОК», в​ ячейке A5 не​ ИСТИНА или ЛОЖЬ​Скопировав формулу в остальные​ 25».​ к 8 марта​ второго оператора.​ Microsoft Excel, следует​ диапазон ячеек с​Для нормального функционирования формулы​от 16-20=18%​ 600 000 ₽.​?​ соответствующие указанному условию.​ Этой формулой выбираем​ «100», если в​ в Excel «ЕСЛИ»​ противном случае —​

​ равняется строке «Винты»​Для выполнения этой задачи​ ячейки таблицы, можно​Функция​ в 100 рублей​

​Для примера возьмем все​ выделить функцию «ЕСЛИ».​ условиями, функция возвращает​ в ячейках с​от 20-25=23%​630 000 ₽​) и звездочку (​ Предположим, например, что​ из таблицы товара​ ячейке A 4​ пригодится в таблицах,​

​ «Неверно» (ОК).​ (ЛОЖЬ).​ используются функции​ увидеть, что на​

Пример функции с несколькими условиями

​ЕСЛИ​ положена только женщинам,​ ту же таблицу​ Это один из​ массив. Для ввода​ текстовыми значениями не​от 25и выше=33%​=СУММЕСЛИ(A2:A5; «>160000»)​*​ в столбце с​ и переносим в​ будет стоять слово​ чтобы посчитать определенные​

​=ЕСЛИ(A2<>15; «ОК»; «Неверно»)​=ИЛИ(A5<>«Винты»;A6 = «Шурупы»)​И​ отлично сдал один​является очень гибкой​ которые входят в​ с выплатами премии​ тех операторов, к​ формулы нужно выделить​ должно пробелов или​Все эти условия​Сумма по имуществу стоимостью​). Вопросительный знак соответствует​ числами необходимо просуммировать​ лист заказа выбранные​ «Да». В ячейке​ данные, в анкетах,​Если значение в ячейке​

​Определяет, выполняется ли следующее​,​ человек, а на​ и ее можно​ число основного персонала.​ к 8 марту.​ которым пользователи прибегают​ такое количество ячеек,​ непечатаемых знаков.​ должны быть в​ больше 1 600 000​ одному любому символу,​ только значения, превышающие​ покупателем позиции.​ В4 написали такую​ в тестах, т.д.​ A2 не равно​ условие: значение в​ИЛИ​ оценки хорошо и​ применять в различных​

​ В этом случае,​ Но, на этот​ чаще всего, при​ как в диапазоне​

​​ одной ячейке да​ ₽.​

Пример с выполнением двух условий одновременно

​ а звездочка — любой​ 5. Для этого​Ещё есть функция​ формулу.​Функция Excel «ЕСЛИ»​ 15, возвращается «ОК»,​

​ ячейке A5 не​и​ плохо по два​ ситуациях. Рассмотрим еще​ если работник мужчина,​ раз, согласно условиям,​ выполнении задач в​ с критериями. После​Посчитаем числовые значения в​ каждой строки столбца.​9 000 000 ₽​ последовательности символов. Если​ можно использовать следующую​ «СЧЁТЕСЛИ» в Excel​=ЕСЛИ(A4=»Да»;100;»»)​находится на закладке​ в противном случае​ равняется строке «Винты»​НЕ​ человека.​ один пример. В​ или относится к​ размер премии зависит​ приложении. Давайте разберемся,​ введения аргументов нажать​ одном диапазоне. Условие​ ПОМОГИТЕ пожалуйста. Никак​

​=СУММЕСЛИ(A2:A5;300000;B2:B5)​ требуется найти непосредственно​ формулу:​ — она считает​

Пример использования оператора «ИЛИ»

​Обратите внимание!​ «Формулы» в разделе​ — «Неверно» (Неверно).​ или значение в​, а также операторы​Как видите, вместо второго​ таблице ниже приведены​

​ вспомогательному персоналу, то​ от категории работника.​ что представляет собой​ одновременно сочетание клавиш​ подсчета – один​ не соображу как​Сумма комиссионных за имущество​ вопросительный знак (или​=СУММЕСЛИ(B2:B25;»>5″)​ количество ячеек по​В третьем условии​ «Библиотека функций» -​=ЕСЛИ(НЕ(A2​ ячейке A6 равняется​ (см. пример ниже).​ и третьего аргументов​ результаты переаттестации сотрудников​ величина его премии​ Женщины, имеющие статус​ функция «ЕСЛИ», и​

​ критерий.​ написать формулу​ стоимостью 3 000 000​ звездочку), необходимо поставить​Это видео — часть​ нашим условиям. Смотрите​ в формуле мы​ «Логические». Встаем на​Если значение в ячейке​ строке «Шурупы» (ИСТИНА).​Чтобы этот пример проще​ функции​

Функция ЕСЛИ в Excel на простом примере

​ будет равна нулю,​​ основного персонала получают​​ как с ней​ + Enter. Excel​У нас есть такая​Алексей матевосов (alexm)​ ₽.​ перед ним знак​ учебного курса сложение​ статью «Функция «СЧЁТЕСЛИ​ поставили не «нуль»,​ ячейку В1, вызываем​ A2 не меньше​Дополнительные сведения об использовании​ было понять, скопируйте​ЕСЛИ​В столбец C нам​​ а иначе –​​ по 1000 рублей​

Читать еще:  Почему в эксель вместо значения показывается формула

Коротко о синтаксисе

​ работать.​​ распознает формулу массива.​​ таблица:​: Значение стажа в​

​210 000 ₽​

​ «тильда» (​ чисел в Excel.​ в Excel». Эту​ а две двойные​ функцию «ЕСЛИ».​ и не равно​ этих функций см.​ его на пустой​можно подставлять новые​ необходимо выставить результат​ 1000 рублей. В​ премии, а вспомогательный​Скачать последнюю версию​

​СЧЕТЕСЛИ с двумя условиями​Посчитаем количество ячеек с​ ячейке А1​=СУММЕСЛИ(A2:A5;»>» &C2;B2:B5)​

​Советы:​ функция может посчитать​ кавычки – это​

​Первый пример.​ 15, возвращается «ОК»,​ в разделах Функция​ лист.​​ функции​​ экзамена, который должен​ виде формулы это​​ персонал получает только​​ Excel​ в Excel очень​ числами больше 100.​Формула с ЕСЛИ​Сумма комиссионных за имущество,​).​ ​

​ ячейки, в которых​​ значит «Пусто» (оставить​​Нам нужно выбрать​ в противном случае​ И, Функция ИЛИ​Копирование примера​ЕСЛИ​ содержать всего два​ выглядит так: «=ЕСЛИ(ИЛИ(B6=»муж.»;​ 500 рублей. Естественно,​

​«ЕСЛИ» является стандартной функцией​ часто используется для​ Формула: =СЧЁТЕСЛИ(B1:B11;»>100″). Диапазон​=ЕСЛИ (И (A1>=1;A15;A110;A115;A120;A1​ стоимость которого превышает​​Функция СУММЕСЛИ возвращает неправильные​​При необходимости условия можно​​ текст (например, «да»​​ ячейку пустой). Скопировали​ из столбца А​ — «Неверно» (Неверно).​ и Функция НЕ.​

  1. ​Выделите пример, приведенный в​, тем самым расширяя​ варианта:​ C6=»Вспомогательный персонал»); «0»;​
  2. ​ что мужчинам этот​​ программы Microsoft Excel.​​ автоматизированной и эффективной​​ – В1:В11. Критерий​​ Формула без ЕСЛИ​
  3. ​ значение в ячейке​ результаты, если она​ применить к одному​ — в анкете).​ формулу в ячейку​ числа «2» и​=ЕСЛИ(A5<>«Винты»; «ОК»; «Неверно»)​
  4. ​К началу страницы​ этой статье.​ число условий, которое​Сдал​ «1000»)». Записываем эту​

Функция ЕСЛИ и несколько условий

​ вид выплат вообще​​ В её задачи​​ работы с данными.​ подсчета – «>100».​=(A1>=1)*(A1<>5)*(A1<>10)*(A1<>15)*(A1<>20)*(A1<>25)*33​ C2.​ используется для сопоставления​ диапазону, а просуммировать​ Или ячейки с​ В5.​ написать в столбце​Если значение в ячейке​Для выполнения этой задачи​​Важно:​​ формула может обработать.​или​ формулу в соответствующую​​ не положен независимо​​ входит проверка выполнения​ Поэтому продвинутому пользователю​​ Результат:​​Формула с ВЫБОР​

    ​490 000 ₽​ строк длиннее 255 символов​ соответствующие значения из​​ числом или числами​​Третий пример.​​ В то значение,​​ A5 не равно​

  • ​ используются функции​ Не выделяйте заголовки строк​ Таким образом, Вы​​Не сдал​​ ячейку таблицы.​ от категории.​ конкретного условия. В​ настоятельно рекомендуется внимательно​Если условие подсчета внести​=ВЫБОР (ЕСЛИ (ОКРВВЕРХ​Скопируйте образец данных из​​ или применяется к​​ другого диапазона. Например,​​ больше, например, 5.​​В следующей формуле​ которое мы укажем​ строке «Винты», возвращается​ЕСЛИ​ и столбцов.​
  • ​ можете создать нужное​. Те, кто набрал​«Протягиваем» результаты вниз.​Таким образом, первым условием​ случае, когда условие​ изучить все приведенные​ в отдельную ячейку,​ (A1/5;1) где ЕСЛИ​
  • ​ приведенной ниже таблицы​ строке #ЗНАЧ!.​ формула​​ Не только посчитать​​ поставили в третьем​ в формуле. Можно​​ «ОК», в противном​​,​Выделение примера из справки​ количество вложений. Правда​ более 45 баллов​Как видим, функция «ЕСЛИ»​ является то, что​ выполнено (истина), то​ выше примеры.​ можно в качестве​ (ОКРВВЕРХ (A1/5;1)​ и вставьте его​Аргумент​=СУММЕСЛИ(B2:B5; «Иван»; C2:C5)​

    ​ ячейки, но и​ условии знак «Тире».​ выбрать любые числа,​ случае — «Неверно»​​И​​Нажмите клавиши CTRL+C.​​ есть очевидный недостаток​​ – сдали экзамен,​

    ​ может оказаться для​ если сотрудник мужчина,​ в ячейку, где​​Посчитаем количество реализованных товаров​​ критерия использовать ссылку:​Loony​ в ячейку A1​диапазон_суммирования​суммирует только те​ вычислить процент определенных​​ =ЕСЛИ(A5=»Да»;100;»-«)​​ слова, т.д.​ (Неверно).​и​Создайте пустые книгу или​ такой конструкции, после​ остальные нет.​ пользователя хорошим помощником​

    ​ то величина получаемой​

    Создание условных формул

    ​ использована данная функция,​ по группам.​Посчитаем текстовые значения в​: ЕСЛИ (. ЕСЛИ. (ЕСЛИ. ))​ нового листа Excel.​может не совпадать​​ значения из диапазона​​ ответов к общему​​В ячейку В6​​Появившееся диалоговое окно​​=ЕСЛИ(И(A2>A3; A2​​ИЛИ​​ лист в Excel.​​ 3-5 вложений формула​

    ​Выделите ячейку, в которую​​ при работе с​​ премии равна нулю.​ возвращается одно значение,​

    ​Сначала отсортируем таблицу так,​

    ​ одном диапазоне. Условие​ ) и так​

    ​ Чтобы отобразить результаты​ по размерам с​

    ​ C2:C5, для которых​ числу ответов.​

    ​ написали такую формулу.​ заполнили так.​Если значение в ячейке​, а также операторы​

    В этой статье

    ​На листе выделите ячейку​ станет нечитаемой и​ необходимо ввести формулу.​ данными в программе​

    ​ Если же данное​ а если не​ чтобы одинаковые значения​ поиска – один​ далее — вложенные​

    Создание условной формулы с результатом, являющимся логическим значением (ИСТИНА или ЛОЖЬ)

    ​ формул, выделите их​ аргументом​​ соответствующие значения из​​Есть ещё функция​​ =ЕСЛИ(A6=»%»;1;»нет») Здесь в​​В формуле «ЕСЛИ» нужно​​ A2 больше значения​​ (см. пример ниже).​ A1 и нажмите​

    ​ громоздкой, и с​ В нашем случае​ Microsoft Excel. Она​ значение ложно, и​

    ​ оказались рядом.​ критерий.​

    ​ операторы.​​ и нажмите клавишу​диапазон​

    ​ диапазона B2:B5 равны​

    ​ в Excel «СУММЕСЛИ».​

    ​ третьем условии написали​ написать три условия.​

    ​ в ячейке A3​Чтобы этот пример проще​ клавиши CTRL+V.​

    ​ ней будет невозможно​​ это ячейка C3.​ позволяет отобразить результаты​ сотрудник не мужчина​ другое.​

    ​Первый аргумент формулы «ПРОМЕЖУТОЧНЫЕ.ИТОГИ»​Формула: =СЧЁТЕСЛИ(A1:A11;»табуреты»). Или:​Stalin​ F2, а затем —​. При определении фактических​ «Иван».​​ Про эту функцию​​ слово «нет» в​​ В формуле эти​​ и меньше значения​​ было понять, скопируйте​​Важно:​

    ​ работать.​Введите в нее выражение:​ соответствующие определенным условиям.​ (т.е. женщина), то​

    Функция ЕСЛИ в Excel с примерами нескольких условий

    Логический оператор ЕСЛИ в Excel применяется для записи определенных условий. Сопоставляются числа и/или текст, функции, формулы и т.д. Когда значения отвечают заданным параметрам, то появляется одна запись. Не отвечают – другая.

    Логические функции – это очень простой и эффективный инструмент, который часто применяется в практике. Рассмотрим подробно на примерах.

    Синтаксис функции ЕСЛИ с одним условием

    Синтаксис оператора в Excel – строение функции, необходимые для ее работы данные.

    Разберем синтаксис функции:

    Читать еще:  Количество символов формула эксель

    Логическое_выражение – ЧТО оператор проверяет (текстовые либо числовые данные ячейки).

    Значение_если_истина – ЧТО появится в ячейке, когда текст или число отвечают заданному условию (правдивы).

    Значение,если_ложь – ЧТО появится в графе, когда текст или число НЕ отвечают заданному условию (лживы).

    Оператор проверяет ячейку А1 и сравнивает ее с 20. Это «логическое_выражение». Когда содержимое графы больше 20, появляется истинная надпись «больше 20». Нет – «меньше или равно 20».

    Внимание! Слова в формуле необходимо брать в кавычки. Чтобы Excel понял, что нужно выводить текстовые значения.

    Еще один пример. Чтобы получить допуск к экзамену, студенты группы должны успешно сдать зачет. Результаты занесем в таблицу с графами: список студентов, зачет, экзамен.

    Обратите внимание: оператор ЕСЛИ должен проверить не цифровой тип данных, а текстовый. Поэтому мы прописали в формуле В2= «зач.». В кавычки берем, чтобы программа правильно распознала текст.

    Функция ЕСЛИ в Excel с несколькими условиями

    Часто на практике одного условия для логической функции мало. Когда нужно учесть несколько вариантов принятия решений, выкладываем операторы ЕСЛИ друг в друга. Таким образом, у нас получиться несколько функций ЕСЛИ в Excel.

    Синтаксис будет выглядеть следующим образом:

    Здесь оператор проверяет два параметра. Если первое условие истинно, то формула возвращает первый аргумент – истину. Ложно – оператор проверяет второе условие.

    Примеры несколько условий функции ЕСЛИ в Excel:

    Таблица для анализа успеваемости. Ученик получил 5 баллов – «отлично». 4 – «хорошо». 3 – «удовлетворительно». Оператор ЕСЛИ проверяет 2 условия: равенство значения в ячейке 5 и 4.

    В этом примере мы добавили третье условие, подразумевающее наличие в табеле успеваемости еще и «двоек». Принцип «срабатывания» оператора ЕСЛИ тот же.

    Расширение функционала с помощью операторов «И» и «ИЛИ»

    Когда нужно проверить несколько истинных условий, используется функция И. Суть такова: ЕСЛИ а = 1 И а = 2 ТОГДА значение в ИНАЧЕ значение с.

    Функция ИЛИ проверяет условие 1 или условие 2. Как только хотя бы одно условие истинно, то результат будет истинным. Суть такова: ЕСЛИ а = 1 ИЛИ а = 2 ТОГДА значение в ИНАЧЕ значение с.

    Функции И и ИЛИ могут проверить до 30 условий.

    Пример использования оператора И:

    Пример использования функции ИЛИ:

    Как сравнить данные в двух таблицах

    Пользователям часто приходится сравнить две таблицы в Excel на совпадения. Примеры из «жизни»: сопоставить цены на товар в разные привозы, сравнить балансы (бухгалтерские отчеты) за несколько месяцев, успеваемость учеников (студентов) разных классов, в разные четверти и т.д.

    Чтобы сравнить 2 таблицы в Excel, можно воспользоваться оператором СЧЕТЕСЛИ. Рассмотрим порядок применения функции.

    Для примера возьмем две таблицы с техническими характеристиками разных кухонных комбайнов. Мы задумали выделение отличий цветом. Эту задачу в Excel решает условное форматирование.

    Исходные данные (таблицы, с которыми будем работать):

    Выделяем первую таблицу. Условное форматирование – создать правило – использовать формулу для определения форматируемых ячеек:

    В строку формул записываем: =СЧЕТЕСЛИ (сравниваемый диапазон; первая ячейка первой таблицы)=0. Сравниваемый диапазон – это вторая таблица.

    Чтобы вбить в формулу диапазон, просто выделяем его первую ячейку и последнюю. «= 0» означает команду поиска точных (а не приблизительных) значений.

    Выбираем формат и устанавливаем, как изменятся ячейки при соблюдении формулы. Лучше сделать заливку цветом.

    Выделяем вторую таблицу. Условное форматирование – создать правило – использовать формулу. Применяем тот же оператор (СЧЕТЕСЛИ).

    Здесь вместо первой и последней ячейки диапазона мы вставили имя столбца, которое присвоили ему заранее. Можно заполнять формулу любым из способов. Но с именем проще.

    Блог о программе Microsoft Excel: приемы, хитрости, секреты, трюки

    Несколько условий ЕСЛИ в Excel

    Функция ЕСЛИ в Excel позволяет оценивать ситуацию с двух точек зрения, например, значение больше 0 или меньше, и в зависимости от ответа на этот вопрос, произведи дальнейшие расчеты по той или иной формуле. Однако, не редки ситуации, когда вам приходится работать более, чем с двумя условиями. В сегодняшней статье мы рассмотрим примеры создания формул в Excel с несколькими условиями ЕСЛИ.

    Прежде, чем начать изучать данный урок, рекомендую прочитать статью про функцию ЕСЛИ, где описаны основные приемы работы.

    Принцип создания формул с несколькими условиями ЕСЛИ заключается в том, что в одном из аргументов формулы (значение_если_ИСТИНА или значение_если_ЛОЖЬ) находится еще одна формула ЕСЛИ.

    Вам также могут быть интересны следующие статьи

    84 комментария

    Нужно вернуть определенное значение из ячейки и посчитать балл, т.е. например в ячейке D3 может быть значение А, Б, В, Г, надо в ячейку D4 вернуть значение в зависимости от буквы, например А=1, Б=2, В=3 и так далее. Как сделать? Можно ли через формулу ЕСЛИ?

    Статья хорошая, спасибо.
    Но.. вначале статьи планы ставят из минимального расчета 500$, а все дальнейшие расчеты исходят из 400$.
    Как бы надо стараться следовать тем планам, что ставите.

    Данный метод хорош, если у нас немного критериев (2-3), но когда их 10, то в такой формуле потом трудно разобратся «что и откуда». В таком случае можно (и нужно) обойтись без ЕСЛИ.
    Для этого создаем маленькую табличку с нашими критериями: в первой строке по возрастанию заполняем критерии (в приведенном примере это будут 0, 500, 750, 1000); во второй строчке под каждым критерием заполняем соответствующий процент (7, 10, 12,5, 16). Допустим, в диапазоне A1:D1 у нас заполнены критерии, а в диапазоне A2:D2 — соответствующие проценты. В ячейке А5 имеем цифру продаж; для рассчета комиссии используем следующую формулу: =A5*ИНДЕКС($A$2:$D$2;ПОИСКПОЗ(A5;$A$1:$D$1;1)).
    ПОИСКПОЗ ищет расположение критерия, который меньше продаж, но наибольший в списке, а ИНДЕКС по полученному номеру выдает нам необходимый процент.

    Примеры использования условий в формулах Excel

    Здравствуйте, друзья! Часто ли вам приходится делать выбор? Например, захотели купить новый телефон, а полной суммы денег у вас нет. Взять кредит или копить? Так сегодня разберем как делать выбор в электронных таблицах Excel. Это позволяет сделать условная функция ЕСЛИ().

    Условная функция ЕСЛИ()

    В этой функции проверяется истинность одного или нескольких логических выражений и выбирается дальнейшее действие. В логических выражениях используют знаки операций отношения между сравниваемыми величинами.

    Читать еще:  Функция впр в excel примеры

    Простое условие

    Что же делает функция ЕСЛИ()? Посмотрите на схему. Здесь приведен простой пример работы функции при определении знака числа а.

    Блок-схема «Простое условие». Определение отрицательных и неотрицательных чисел

    Условие а>=0 определяет два возможных варианта: неотрицательное число (ноль или положительное) и отрицательное. Ниже схемы приведена запись формулы в Excel. После условия через точку с запятой перечисляются варианты действий. В случае истинности условия, в ячейке отобразится текст «неотрицательное», иначе — «отрицательное». То есть запись, соответствующая ветви схемы «Да», а следом – «Нет».

    Текстовые данные в формуле заключаются в кавычки, а формулы и числа записывают без них.

    Если результатом должны быть данные, полученные в результате вычислений, то смотрим следующий пример. Выполним увеличение неотрицательного числа на 10, а отрицательное оставим без изменений.

    Блок-схема «Простое условие». Расчет данных

    На схеме видно, что при выполнении условия число увеличивается на десять, и в формуле Excel записывается расчетное выражение А1+10 (выделено зеленым цветом). В противном случае число не меняется, и здесь расчетное выражение состоит только из обозначения самого числа А1 (выделено красным цветом).

    Это была краткая вводная часть для начинающих, которые только начали постигать азы Excel. А теперь давайте рассмотрим более серьезный пример с использованием условной функции.

    Задание:
    Процентная ставка прогрессивного налога зависит от дохода. Если доход предприятия больше определенной суммы, то ставка налога выше. Используя функцию ЕСЛИ, рассчитайте сумму налога.

    Решение:

    Решение данной задачи видно на рисунке ниже. Но внесем все-таки ясность в эту иллюстрацию. Основные исходные данные для решения этой задачи находятся в столбцах А и В. В ячейке А5 указано пограничное значение дохода при котором изменяется ставка налогообложения. Соответствующие ставки указаны в ячейках В5 и В6. Доход фирм указан в диапазоне ячеек В9:В14. Формула расчета налога записывается в ячейку С9: =ЕСЛИ(B9>A$5;B9*B$6;B9*B$5). Эту формулу нужно скопировать в нижние ячейки (выделено желтым цветом).

    В расчетной формуле адреса ячеек записаны в виде A$5, B$6, B$5. Знак доллара делает фиксированной часть адреса, перед которой он установлен, при копировании формулы. Здесь установлен запрет на изменение номера строки в адресе ячейки.

    Составное условие

    Составное условие состоит из простых, связанных логическими операциями И() и ИЛИ().

    И() — логическая операция, требующая одновременного выполнения всех условий, связанных ею.
    ИЛИ() — логическая операция, требующая выполнения любого из перечисленных условий, связанных ею.

    Логическая операция И()

    Например: Рассмотрим электронную таблицу «Ведомость сдачи вступительных экзаменов». Для зачисления абитуриента в ВУЗ, ему необходимо преодолеть проходной балл, и по математике отметка должна быть выше 70 баллов.
    Посмотрите внимательно на рисунок ниже.

    В этом примере функция ЕСЛИ() использует составное условие, связанное логической операцией И(). Обратите внимание: абитуриент Петров не зачислен, хотя сумма его баллов равна проходному.

    Почему так произошло? Посмотрим внимательно на условие в нашей формуле =ЕСЛИ(И(E6>=D2;B6>70);»зачислен»;»не зачислен»). Логическая операция И() требует выполнения всех условий, но у нас выполняется только одно. Второе условие B6>70 не выполнено, поэтому составное условие принимает значение «ложь». И на экран выводится сообщение «не зачислен» (вспоминаем схему – ветвь «нет»).

    Задание:
    В торговой фирме перед Новым Годом устроена праздничная распродажа. Рассчитать сумму продаж с учетом скидки, назначаемой в период распродажи.

    1. Рассчитайте общую стоимость продаж. Итого = Стоимость* Количество.

    2. Определите скидку (в процентах), используя функцию ЕСЛИ(). Если дата продажи попадает в период праздничной распродажи, то назначается скидка, иначе скидка равняется нулю. При задании условий используйте логическую функцию И().

    3. Определите сумму продажи с учетом скидки. Сумма продажи с учетом скидки = Итого* (1- Скидка%).

    Решение:

    Для проведения расчетов необходимо вписать следующие формулы:

    • В ячейке Е7: =B7*C7
    • В ячейке F7: =ЕСЛИ(И(D7>=D$4;D7

    Абитуриент Сидоров зачислен, хотя не набрал проходной балл. Вот формула =ЕСЛИ(ИЛИ(B7>60;E7>D2;);»зачислен»;»не зачислен»). Здесь использована операция ИЛИ(), поэтому достаточно выполнение хотя бы одного условия. Что и произошло, первое условие B7>60 истинно. Оно привело к выводу сообщения о зачислении абитуриента.

    Задание:
    В торговой фирме установлены дни распродаж — последние числа месяца. Рассчитать сумму продаж с учетом скидки, назначаемой в дни распродажи.

    1. Рассчитайте общую стоимость продаж. Итого = Стоимость* Количество.

    2. Определите скидку (в процентах), используя функцию ЕСЛИ(). Если дата продажи совпадает с датами распродаж, то назначается скидка, иначе скидка равняется нулю. При задании условий используйте логическую функцию ИЛИ().

    3. Определите сумму продажи с учетом скидки. Сумма продажи с учетом скидки = Итого* (1- Скидка%)

    Решение:

    Для проведения расчетов необходимо вписать следующие формулы:

    • В ячейке Е7: =B7*C7
    • В ячейке F7: =ЕСЛИ(ИЛИ(D7=D$4;D7=E$4;D7=F$4);B$4;0)
    • В ячейке G7: =E7*(1-F7)

    и скопировать по соответствующим столбцам до 15 строки включительно.

    Вложенные условия

    Если для решения задачи недостаточно использования составных условий, то тогда применяют более сложную конструкцию вложенных условий. Смотрите схему.

    В данном примере вторая функция ЕСЛИ() является вложенной и записывается на месте действия, которое вызывается при не выполнении условия первой функции. В Excel последних версий допускается делать до 64 вложений.

    Задание:
    С целью уменьшения текучести кадров администрация решила выплачивать надбавку за непрерывный стаж работы на своем предприятии. Рассчитайте надбавку за непрерывный стаж работы в соответствии с таблицей Надбавка.

    1. Определите стаж работы сотрудников. Стаж = 2018- Год приема на работу.

    2. Используя вложенные функции Если, рассчитайте надбавку для сотрудников. Надбавка (руб.) = Надбавка(%)* Оклад

    Решение:

    Для проведения расчетов необходимо вписать следующие формулы:

    • В ячейке D9: =2018-B9
    • В ячейке E9: =ЕСЛИ(D9>=B$6;C9*C$6;ЕСЛИ(D9>=B$5;C9*C$5;0))

    и скопировать по соответствующим столбцам до 19 строки включительно.

    В этой статье я постарался максимально подробно и доходчиво объяснить применение условной функции в Excel. Конечно же, в Excel есть и другие функции с условием, но о них поговорим в следующей статье. Друзья, если вам была интересна и полезна данная информация, не забывайте делиться ею в социальных сетях. А также буду рад прочитать ваши комментарии.

    Дополнительная информация:

    PS: Удивительные факты

    Похожие статьи

    Ссылка на основную публикацию
    Похожие публикации
    Adblock
    detector