Округление в excel до сотых

Округление чисел в Microsoft Excel

Стандартная функция

Дробные числа в электронных таблицах Excel можно выводить на экран с разной степенью точности:

  • самый простой способ – на вкладке «Главная» нажимаем кнопки «Увеличить разрядность» или «Уменьшить разрядность»;
  • щелкаем правой кнопкой мыши по ячейке, в раскрывшемся меню выбираем «Формат ячеек…», далее вкладка «Число», выбираем формат «Числовой», определяем, сколько будет десятичных знаков после запятой (по умолчанию предлагается 2 знака);
  • щелкаем ячейку, на вкладке «Главная» выбираем «Числовой», либо идем на «Другие числовые форматы…» и там настраиваем.

Вот как выглядит дробь 0,129, если менять количество десятичных знаков после запятой в формате ячейки:

Обратите внимание, в A1,A2,A3 записано одно и то же значение, меняется только форма представления. При дальнейших расчетах будет использоваться не величина, видимая на экране, а исходная. Начинающего пользователя электронных таблиц это может слегка запутать. Чтобы реально изменить значение, необходимо использовать специальные функции, их в Excel несколько.

Формула округление

Одна из часто применяемых функций округления – ОКРУГЛ. Она работает по стандартным математическим правилам. Выбираем ячейку, щелкаем значок «Вставить функцию», категория «Математические», находим ОКРУГЛ.

Определяем аргументы, их два – сама дробь и количество разрядов. Щелкаем «ОК» и смотрим, что получилось.

К примеру, выражение =ОКРУГЛ(0,129;1) даст результат 0,1. Нулевое количество разрядов позволяет избавляться от дробной части. Выбор отрицательного количества разрядов позволяет округлять целую часть до десятков, сотен и так далее. Например, выражение =ОКРУГЛ(5,129;-1) даст 10.

Округляем в большую или меньшую сторону

В Excel представлены и другие средства, позволяющие работать с десятичными дробями. Одно из них – ОКРУГЛВВЕРХ, выдает самое близкое число, большее по модулю. Например, выражение =ОКРУГЛВВЕРХ(-10,2;0) даст -11. Количество разрядов здесь 0, значит, получим целое значение. Ближайшее целое, большее по модулю, – как раз -11. Пример использования:

ОКРУГЛВНИЗ аналогична предыдущей функции, но выдает ближайшее значение, меньшее по модулю. Различие в работе вышеописанных средств видно из примеров:

Как правильно округлить число в Excel и Google Таблицах: все способы с подробной инструкцией

К таблицам у всех нас разное отношение, кто-то их очень любит и “рисует” по каждому поводу, кто-то терпеть не может. Но всем нам иногда приходится с ними работать, поэтому полезно знать основные возможности табличного редактора и дополнительные фишки, например, закрепление строк, использование сортировки и фильтров. Такие инструменты могут здорово облегчить жизнь.

Сегодня же мы говорим о том, как округлить число в Excel, какие есть способы, для чего это нужно, и как правильно применять функции.

Под округлением каждый из нас может понимать что-то свое, поэтому давайте рассмотрим, какие варианты есть в Excel:

  1. Простое отбрасывание дробной части. Например, у нас есть число 12,3456, мы же хотим видеть только десятые и сотые доли, большая точность нас не интересует. Отбрасыванием дробной части мы получим результат 12,34. Такой способ часто используется для красоты, чтобы не перегружать таблицу и себя лишними знаками. В таком случае для решения задачи можно использовать формат ячеек.
  2. Математическое округление. В данном случае часть знаков после запятой отбрасывается, но при этом учитывается следующая цифра после значимого для нас разряда. Мы смотрим, она больше 5 или меньше. Например, у нас есть число 12,57. Мы хотим округлить его до десятых. Тогда по правилам математики мы получаем 12,6. То есть мы увеличили десятые доли на 1, потому что сотые больше 5. Если бы мы округляли 12,52, то получили бы 12,5.
  3. Округление до ближайшего большего или меньшего числа, так называемое округление “вверх” и округление “вниз” соответственно. Например, у нас есть исходные данные: 12,75, 12,31, 11,89, которые мы хотим преобразовать в целые величины. Если мы используем округление “вниз”, то получим 12, 12, 11. Если округляем в большую сторону, то получим 13, 13, 12.
  4. Округление до десятков, сотен, тысяч и так далее. Этот вариант бывает полезен, когда нам нужны приблизительные вычисления, без детализации.
  5. Округление до ближайшего четного и нечетного значения.
  6. Округление до ближайшего кратного какой-то величине числа. Например, у нас есть 124 конфеты, а в 1 коробку вмещается 13 конфет. И мы хотим понять, сколько конфет у нас разместится в коробках по 13 штук. Тогда мы будем округлять 124 до меньшего целого числа кратного 13 и получим результат 117.

Для каждого из этих случаев в Excel есть своя функция округления. Давайте научимся ими пользоваться. Но сначала посмотрим, как можно изменить внешний вид данных в таблице.

Формат ячеек

Часто нам нужно не фактическое округление, а просто аккуратный единый вид всех чисел в таблице. В таком случае мы не используем формулы, а просто меняем внешний вид данных.

Для этого выделяем ячейки в таблице и нажимаем правую кнопку мыши. В контекстном меню выбираем нужный раздел.

Во вкладке “Число” выбираем подходящий формат.

“Общий” используется по умолчанию и отображает данные в ячейках так, как они есть, изменить внешний вид тут не получится.

“Числовой” позволяет отображать столько знаков после запятой, сколько нужно, или вовсе убрать дробную часть.

“Денежный” и “Финансовый” похожи на “Числовой”, но позволяют также указывать валюту.

В “Процентном” тоже можно регулировать количество знаков после запятой. Если мы переключаемся на этот формат, то исходные данные в ячейках умножаются на 100, и добавляется значок %.

Я для своих вычислений чаще всего пользуюсь числовым форматом. Он универсальный и позволяет быстро привести ячейки к единому виду.

Этот способ подходит для Excel любого года выпуска. Если у вас новая версия программы, то решить задачу можно еще быстрее. Для этого во вкладке “Главная” есть специальный блок опций. Тут можно выбрать подходящий формат из выпадающего списка, а стрелочками влево и вправо увеличить или уменьшить количество разрядов.

Внимание: при изменении формата данных фактические значения в ячейках не меняются, они остаются прежними, просто отображаются по-другому.

Как работать с функциями в Excel

Мы рассмотрели самый простой способ убрать лишние знаки. Использовать его довольно удобно, если менять сами данные в таблице нам не нужно. Теперь мы переходим к использованию различных функций. Но сначала я хочу напомнить вам, что это такое, а также как с ними работать.

Читать еще:  В excel

Функции ускоряют и упрощают вычисления. Например, нам надо посчитать сумму в столбце, в котором 100 значений. Мы можем делать это самым прямым способом “1+20+30+43. ” и так 99 раз. Или написать встроенную команду “СУММ”, указать диапазон ячеек, и программа за секунду сделает расчеты.

Первый способ

Чтобы вручную написать формулу в ячейке с использованием функции, обязательно нужно:

  1. Поставить знак =.
  2. Правильно указать название.
  3. Открыть круглую скобку.
  4. Указать через точку с запятой аргументы, то есть данные, которые будут использоваться.
  5. Закрыть скобку.

Что может выступать аргументом математических формул:

Пример: функция “=СУММ(F21:F30)” посчитает сумму чисел, написанных в столбце F с позиции F21 до F30.

Эти правила нужно запомнить, иначе программа не сможет сделать вычисления, а будет выдавать ошибку такого вида.

Второй способ

Если неудобно писать команды вручную, то можно воспользоваться библиотекой, которая находится во вкладке “Формулы”.

Нас в данный момент интересуют математические операции. Нажимаем на соответствующий раздел и выбираем нужную процедуру.

Откроется диалоговое окно, в котором легко понять, какие аргументы нужно указать. Заполните поля и нажмите “ОК”.

Отбрасывание дробной части

Этот способ подойдет, если нам не важно, произойдет ли округление по математическим законам, и в какую сторону изменится значение. Когда мы просто хотим упростить вычисления, убрав лишние знаки, то можем отбросить их. Для этого есть функция “ОТБР”, которая содержит 2 параметра:

  • число, над которым нужно произвести действие;
  • количество знаков после запятой, которое следует оставить.

Например, у нас есть цена товара 4 716 рублей 77 копеек и еще уйма знаков после запятой. Логично отбросить все лишнее и получить только рубли и копейки.

Если же мы хотим получить только рубли без копеек, то вторым аргументом пишем не 2, а 0.

Математическое округление

Для привычного нам со школы математического действия есть специальная функция “ОКРУГЛ”. Она нужна для работы с дробными частями и целочисленными значениями. Аргументами выступают число и количество разрядов, которые нужно оставить после запятой.

Например, у нас есть значение 34,83021, и мы хотим округлить его с точностью до сотых. Тогда формула будет выглядеть так: “=ОКРУГЛ(34,83021;2)”.

Если в качестве второго аргумента указать 0, то получим целочисленное значение, то есть округлим первоначальные данные до единиц. А если количество разрядов будет отрицательным, то преобразовываться будет уже целое число.

Например, мы хотим округлить до сотен 1245,329. Тогда делаем такую запись в ячейке нашей таблицы: “=ОКРУГЛ(1245,329;-2)” и получаем результат 1 200.

В меньшую и большую сторону

Бывает так, что нам не нужно точное математическое вычисление, а важно не преувеличить или, наоборот, не уменьшить значение в ячейке. Тогда мы будем округлять в меньшую или большую сторону.

До дробных частей

Чтобы округлить в меньшую или большую сторону, есть универсальные функции “ОКРУГЛВНИЗ” и “ОКРУГЛВВЕРХ”. Они позволяют делать преобразования с точностью до целых и дробных частей.

Первый аргумент – это число, которое требуется округлить. Второй – количество разрядов. Если он больше 0, то показывает, сколько знаков после запятой должно остаться, если меньше 0, то происходит округление до десятков, сотен, тысяч. Если аргумент равен 0, то мы получаем точность до единиц, дробная часть отбрасывается.

Давайте посмотрим на примере работу этих двух команд.

Есть еще один способ округлить в меньшую или большую сторону. Для этого нам понадобятся функции “ОКРВНИЗ” и “ОКРВВЕРХ”. Они применяются для получения целочисленного результата.

Второй аргумент показывает, до какого разряда мы округляем:

  • 10 – до десятков;
  • 100 – до сотен;
  • 1 000 – до тысяч и т. д.

Показываю на примере.

Округление “вниз” до единиц можно заменить функцией “ЦЕЛОЕ”, у которой есть единственный аргумент – число. Результат будет таким же, как при использовании “ОКРВНИЗ”.

Округлить в большую сторону до ближайшего четного или нечетного целого значения помогают действия “ЧЁТН” и “НЕЧЁТ”. Пример использования одного из них вы видите на скриншоте.

До целых с учетом кратности

Помните пример с конфетами, который был в начале статьи? Сейчас мы научимся округлять до ближайшего кратного какой-то величине значения. Для этого служат 2 функции: “ОКРВНИЗ.МАТ” и “ОКРВВЕРХ.МАТ”. Первая уменьшает исходную величину, а вторая соответственно увеличивает.

Например, у нас есть число 124, и мы хотим округлить его до ближайшего большего кратного 5 значения. Тогда пишем в ячейке: “=ОКРВВЕРХ.МАТ(124;5)” и в результате получаем 125.

В Google Таблицах

Если вы любите работать в режиме онлайн, то можете задать формулу для округления данных в Google Таблицах.

Чтобы изменить формат ячеек, используйте опцию на основной панели инструментов.

Для уменьшения или увеличения разрядности также есть соответствующий инструмент.

Чтобы открыть перечень встроенных формул, нажмите на маленький черный треугольник рядом со значком суммы.

Чтобы округлить данные в ячейках, наводим курсор на математические функции и выбираем один из вариантов:

Работают они точно так же, как в Excel, но в Google Таблицах нет действий “ОКРВНИЗ.МАТ” и “ОКРВВЕРХ.МАТ”. Вместо них можно использовать “ОКРУГЛТ”, эта функция округляет до ближайшей кратной определенному числу величины. То есть в данном случае программа сама решает, в большую или меньшую сторону изменятся исходные данные.

Заключение

Мы рассмотрели все основные способы округления чисел в Microsoft Excel и Google Таблицах. Конечно, есть много частных случаев, которые требуют нетривиального решения. Если вы столкнулись с ситуацией, которая не описана в этой статье, напишите комментарий, и я постараюсь помочь и подсказать, как правильно составить формулу.

Как округлять числа в Excel

В статье рассмотрено, как округлить число в Excel с помощью различных функций, таких как ОКРУГЛ, ОКРУГЛВНИЗ, ОКРУГЛВВЕРХ и другие методы округления. Также приведены примеры формул, как округлить до целого числа, до десятых, до тысяч, до 5, 10 или 100, как округлить кратному числу, а также много других примеров.

Округлить число в путем изменения формата ячейки

Если вы хотите округлить числа в Excel исключительно для визуальной презентации, вы можете изменить формат ячейки, выполнив следующие шаги:

  1. Выберите ячейку с числами, которые вы хотите округлить.
  2. Откройте диалоговое окно « Формат ячеек », нажав Ctrl+1 или щелкните правой кнопкой мыши по ячейке и выберите « Формат ячеек » в контекстном меню.
Читать еще:  Excel округление до целого

Как округлить число в Excel – Формат ячеек
  1. Во вкладке « Число » выберите « Числовой » или « Денежный » формат и введите число десятичных знаков, которое вы хотите отобразить в поле « Число десятичных знаков ». Предварительный просмотр, как будет округлено число отобразится в разделе « Образец ».
  2. Нажмите кнопку « ОК », чтобы сохранить изменения и закрыть диалоговое окно.

Как округлить число в Excel – Округлить число, изменением формата ячейки

Обратите внимание! Этот метод изменяет формат отображения без изменения фактического значения, хранящегося в ячейке. Если вы ссылаетесь на эту ячейку в любых формулах, то во всех вычислениях будет использоваться исходное число без округления. Если вам необходимо фактически округлить число в ячейке, то используйте функции округления Excel.

Как округлить число функцией ОКРУГЛ

ОКРУГЛ – это основная функция округления чисел в Excel, которая округляет число до указанного количества знаков.

Синтаксис :

Число — любое действительное число, которое вы хотите округлить. Это может быть число или ссылка на ячейку.

Число_разрядов — количество знаков для округления числа. Вы можете указать положительное или отрицательное значение в этом аргументе:

  • Если число_разрядов больше 0, число округляется до указанного количества десятичных знаков. Например, =ОКРУГЛ(17,25; 1) округляет число 17,25 до 17,3.

Чтобы округлить число до десятых, укажите в аргументе число_разрядов значение равное 1.

Как округлить число в Excel – Как округлить число до десятых

Если необходимо округлить число до сотых, задайте аргумент число_разрядов равным 2.

Как округлить число в Excel – Как округлить число до сотых

Для того чтобы округлить число до тысячных, введите 3 в число_разрядов.

Как округлить число в Excel – Как округлить число до тысячных
  • Если число_разрядов меньше 0, все десятичные разряды удаляются, а число округляется слева от десятичной точки (до десятых, до сотен, до тысяч и т. д.). Например, =ОКРУГЛ(17,25; -1) округляет 17,25 к ближайшему кратному 10 числу и возвращает в результате 20.
  • Если число_разрядов равно 0, число округляется до ближайшего целого числа (без десятичных знаков). Например, =ОКРУГЛ(17,25; 0) округляет 17,25 до 17.

На следующем изображении демонстрируются несколько примеров, как округлить число в Excel в формуле ОКРУГЛ:

Как округлить число в Excel – Примеры формул, как округлить число, функцией ОКРУГЛ

Как округлить число в большую сторону функцией ОКРУГЛВВЕРХ

Функция ОКРУГЛВВЕРХ округляет число вверх (от 0) до заданного количества цифр.

Синтаксис :

Число — число для округления.

Число_разрядов — количество знаков, до которых вы хотите округлить число. Вы можете указать как положительные, так и отрицательные числа в этом аргументе, и он работает как число_разрядов функции ОКРУГЛ, описанной выше, за исключением того, что число всегда округляется в большую сторону.

Как округлить число в Excel – Примеры формул, как округлить число в большую сторону, функцией ОКРУГЛВВЕРХ

Как округлить число в меньшую сторону функцией ОКРУГЛВНИЗ

Функция ОКРУГЛВНИЗ в Excel делает противоположное тому, что делает ОКРУГЛВВЕРХ, т. е. округляет число вниз.

Синтаксис :

Число — число, подлежащее округлению.

Число_разрядов — количество знаков, до которых вы хотите округлить число. Работает как аргумент число_разрядов функции ОКРУГЛ, за исключением того, что число всегда округлено в меньшую сторону.

Следующее изображение демонстрирует, как округлить число в Excel в меньшую сторону функцией ОКРУГЛВНИЗ в действии.

Как округлить число в Excel – Примеры формул, как округлить число в меньшую сторону, функцией ОКРУГЛВНИЗ

Так выполняется округление чисел в Excel. Надеюсь, теперь вы знаете, как среди всех этих способов, как округлить число в Excel, выбрать наиболее подходящий для ваших нужд.

Округление числа до необходимого десятичного разряда

Если отображение ненужных разрядов вызывает появление знаков ######, или если микроскопическая точность не нужна, измените формат ячеек таким образом, чтобы отображались только необходимые десятичные разряды.

Или если вы хотите округлить число до ближайшего крупного разряда, например, тысячной, сотой, десятой или единицы, используйте функцию в формуле.

С помощью кнопки

Выделите ячейки, которые нужно отформатировать.

На вкладке Главная выберите команду Увеличить разрядность или Уменьшить разрядность, чтобы отобразить больше или меньше цифр после запятой.

С помощью встроенного числового формата

На вкладке Главная в группе Число щелкните стрелку рядом со списком числовых форматов и выберите пункт Другие числовые форматы.

В списке Категория выберите значение Денежный, Финансовый, Процентный или Экспоненциальный в зависимости от типа ваших данных.

В поле Число десятичных знаков введите число знаков после запятой, которые вы хотите отображать.

С помощью функции в формуле

Округлите число до необходимого количества цифр с помощью функции ОКРУГЛ. Эта функция имеет только два аргумента (аргументы — это части данных, необходимые для выполнения формулы).

Первый аргумент — это число, которое необходимо округлить. Он может быть ссылкой на ячейку или числом.

Второй аргумент — это количество цифр, до которого необходимо округлить число.

Предположим, что ячейка A1 содержит число 823,7825. Вот как можно округлить его.

Чтобы округлить до ближайшей тысяч и

Введите =ОКРУГЛ(A1;-3), что равно 100

Число 823,7825 ближе к 1000, чем к 0 (0 кратно 1000 )

В этом случае используется отрицательное число, поскольку округление должно состоятся влево от запятой. Такое же число применяется в следующих двух формулах, которые округляют до сотен и десятков.

Чтобы округлить до ближайших сотен

Введите =ОКРУГЛ(A1;-2), что равно 800

Число 800 ближе к 823,7825, чем к 900. Наверное, теперь вам все понятно.

Чтобы округлить до ближайших десятков

Введите =ОКРУГЛ(A1;-1), что равно 820

Чтобы округлить до ближайших единиц

Введите =ОКРУГЛ(A1;0), что равно 824

Используйте ноль для округления числа до ближайшей единицы.

Чтобы округлить до ближайших десятых

Введите =ОКРУГЛ(A1;1), что равно 823,8

В этом случает для округления числа до необходимого количества разрядов используйте положительное число. То же самое касается двух следующих формул, которые округляют до сотых и тысячных.

Читать еще:  Из ворд в эксель

Чтобы округлить до ближайших сотых

Введите =ОКРУГЛ(A1;2), что равно 823,78

Чтобы округлить до ближайших тысячных

Введите =ОКРУГЛ(A1;3), что равно 823,783

Округлите число в большую сторону с помощью функции ОКРУГЛВВЕРХ. Она работает точно так же, как функция ОКРУГЛ, за исключением того, что она всегда округляет число в большую сторону. Например, если необходимо округлить число 3,2 до ноля разрядов:

=ОКРУГЛВВЕРХ(3,2;0), что равно 4

Округлите число вниз с помощью функции ОКРУГЛВНИЗ. Она работает точно так же, как функция ОКРУГЛ, за исключением того, что она всегда округляет число в меньшую сторону. Например, необходимо округлить число 3,14159 до трех разрядов:

=ОКРУГЛВНИЗ(3,14159;3), что равно 3,141

Совет: Чтобы познакомиться с другими примерами и поработать с ними в книге Excel Online, см. статьи Функция ОКРУГЛ,Функция ОКРУГЛВВЕРХ и Функция ОКРУГЛВНИЗ.

Стандартный десятичный разделитель для чисел можно настроить в параметрах Excel.

Щелкните Параметры (в Excel 2010–2016) или нажмите кнопку Microsoft Office и выберите Параметры Excel (в Excel 2007).

В категории Расширенные параметры нужно выбрать пункт Параметры правки, а затем установить флажок Автоматическая вставка десятичной запятой.

В поле Число знаков после запятой введите положительное число для количества цифр справа от запятой или отрицательное число для количества цифр слева от запятой.

Примечание: Например, если ввести 3 в поле Число знаков после запятой, а затем — 2834 в ячейке, то значение будет равно 2,834. Если ввести –3 в поле Число знаков после запятой, а затем — 283 в ячейке, то значение будет равно 283000.

Нажмите кнопку ОК.

В строке состояния будет отображаться индикатор Фиксированный десятичный формат.

Выберите ячейку на листе и введите нужное число.

Примечание: Установка флажка Фиксированный десятичный формат не влияет на уже введенные данные.

Чтобы не использовать для числа параметр «Фиксированный десятичный формат», при его вводе добавьте десятичную запятую.

Чтобы удалить десятичные запятые из чисел, введенных с использованием фиксированного десятичного формата, сделайте следующее:

Щелкните Параметры (в Excel 2010–2016) или нажмите кнопку Microsoft Office и выберите Параметры Excel (в Excel 2007).

В категории Расширенные параметры в разделе Параметры правки снимите флажок Автоматическая вставка десятичной запятой.

В пустой ячейке введите число, соответствующее числу десятичных знаков, которое вы хотите удалить, например 10, 100 или 1000.

Например, введите 100 в ячейке, если числа содержат два десятичных знака и вы хотите преобразовать их в целые числа.

На вкладке Главная в группе Буфер обмена нажмите кнопку Копировать (или нажмите клавиши CTRL+C).

Выделите на листе ячейки, содержащие числа с десятичными разрядами, которые вы хотите изменить.

На вкладке Главная в группе Буфер обмена щелкните стрелку под кнопкой Вставить и выберите команду Специальная вставка.

В диалоговом окне Специальная вставка в разделе «Операция» выберите Умножить.

Дополнительные сведения

Вы всегда можете задать вопрос специалисту Excel Tech Community, попросить помощи в сообществе Answers community, а также предложить новую функцию или улучшение на веб-сайте Excel User Voice.

ШКОЛА ПРОГРАММИРОВАНИЯ

Сообщение об ошибке

Функции округления чисел в Excel

При работе с функциями в Excel, Вы наверно замечали набор функций ОКРУГЛ(), ОКРВВЕРХ(), ОКРВНИЗ(), ОКРУГЛВВЕРХ(), ОКРУГЛВНИЗ() категории «Математические». В чем отличия между этими функциями и как они работают?

Ранее, в статье «Формат данных в Excel», я описывал форматы представления данных в Excel. С помощью представления можно добавить или сократить дробную часть числа, но фактический формат числа остается неизменным. Часто, при делении чисел, дробная часть получается очень длинной, что в дальнейшем может мешать при некоторых расчетах и выдавать результат не тот, который ожидался. Для того чтобы сократить дробную часть числа (округлить), используется функция ОКРУГЛ(), в которой можно указать необходимое число разрядов после запятой. Также возможно округление и целой части.

Округление происходит следующим образом:
-Если число меньше 5, то следующий разряд остается неизменным.
-Если число равно или больше 5, то к следующему разряду добавляется единица.

Например, число 2553,5675643 после округления до сотых будет выглядеть 2553,57
В общем, округление по школьной программе 🙂

Теперь рассмотрим как работает функция ОКРУГЛ() и какие имеет аргументы.

Синтаксис функции прост — ОКРУГЛ(Число; Число разрядов).

  • Число – в этом аргументе указывается ссылка на ячейку с числом, которое необходимо округлить или вводите значение. Допускает использование других функции, результатом которых является число.
  • Число разрядов — значение этого аргумента указывает, до какого разряда необходимо округлить число. При указании в этом аргументе положительного числа, округление будет происходить после запятой. При нуле, округление до целой части. При указании отрицательного аргумента, округляется целая часть. При этом, кол-во разрядов в целой части, сохраняется и заполняется нулями.

Пример:
Округлим число 2553,5675643
Запись функции следующая:

«=ОКРУГЛ(2553,5675643;2)» вернет результат 2553,57
«=ОКРУГЛ(2553,5675643;0)» вернет 2554
«=ОКРУГЛ(2553,5675643;-2)» вернет 2600

В Excel так же есть функции ОКРВВЕРХ(), ОКРВНИЗ(), ОКРУГЛВВЕРХ(), ОКРУГЛВНИЗ(). Все эти функции практически аналогичны работе с функцией ОКРУГЛ(), но у каждой из них немного иной алгоритм округления.

Функция:
ОКРВВЕРХ() — функция округляет число до ближайшего целого, которое кратно числу, указанного в аргументе «точность«. Округление происходит в большую сторону.

Примеры:
«=ОКРВВЕРХ(2553,57;1)», результат 2554
«=ОКРВВЕРХ(2553,57;3)», вернет результат кратный 3 т.е. 2556

Для округления отрицательных чисел, аргумент «точность» должен быть также отрицательным, иначе функция вернет ошибку «#ЧИСЛО!»
«=ОКРВВЕРХ(-2553,57;-2)», результат -2554

И еще один пример округления, но уже дробного числа
«=ОКРВВЕРХ(0,578;0,02)» результат 0,58

ОКРВНИЗ() функция аналогична ОКРВВЕРХ(), с той лишь разницей что округление происходит в меньшую сторону.
«=ОКРВНИЗ(2553,57;2)» результат 2552

ОКРУГЛВВЕРХ(), ОКРУГЛВНИЗ() — функции по принципу работы схожи с функцией ОКРУГЛ(). Отличие в том, что эти функции округляют число с избытком(недостатком).

Примеры:
«=ОКРУГЛВВЕРХ(2553,34;1)», результат получится 2553,4
«=ОКРУГЛВВЕРХ(2553,34;-1)», результат 2560
«=ОКРУГЛВНИЗ(2553,34;1)», результат 2553,3
«=ОКРУГЛВНИЗ(2553,34;-1)», результат 2550

Похожие статьи

Ссылка на основную публикацию
Похожие публикации
Adblock
detector