Формула произведения в excel

Сумма произведений в Excel

В Microsoft Excel можно проводить разные расчеты, от самых элементарных до более сложных, где задаются определенные условия. Вот и задачу, которую мы с Вами сейчас рассмотрим можно решить по-разному.

В этой статье я покажу, как рассчитать сумму произведений в Excel различными способами: используя привычные «+» и «*» , ссылаясь на определенные ячейки или с помощью функции СУММПРОИЗВ .

Возьмем следующий пример: умножим пары чисел, а затем просуммируем их самым простым способом.

Поставьте в ячейку «=» и начните вписывать значения, расставляя между числами знаки суммы и умножения. Эксель посчитает по законам математики – сначала умножит, а потом прибавит. Чтобы получить результат, жмите «Enter» .

Если у Вас все значения были записаны как и в примере в А1 , то можно не переписывать, достаточно выделить ячейку и поставить в строке формул знак равенства в самом начале.

Еще один вариант – это ссылаться на определенные ячейки, которые берутся для расчета. Преимущества такого способа в том, что если у Вас поменяются значения, например, в заполненной таблице, то сумму произведений не придется исправлять вручную, меняя там числа, все произойдет автоматически.

Для этого поставьте знак равно и выделяйте мышкой ячейки, расставляя между их адресами «+» или «*» . Потом нажмите «Enter» .

Теперь если я изменю в С1 число 24 на 3, результат в D6 будет пересчитан.

Для расчета суммы произведений в Эксель так же есть специальная формула – СУММПРОИЗВ . Ее использование перед предыдущими способами очевидны: автоматический расчет значений при их изменении, возможность задавать определенные условия, работа с большими массивами.

Примеры СУММПРОИЗВ в Excel, я приводила в отдельной статье, там же и рассказывала, как ей пользоваться.

Давайте возьмем такую таблицу. Посчитаем, сколько заработали, умножив количество проданных фруктов на цену реализации за килограмм. Для этого нужно записать формулу такого вида, указав в качестве аргументов нужные диапазоны со значениями:

Если у Вас таблица с большим количеством строк, то можно сделать и по-другому. В качестве аргументов для функции указывайте все столбцы полностью: (E:E;G:G) . Теперь перемножаются 10 и 216, 5 и 114, 8 и 96 и так далее.

В аргументах к СУММПРОИЗВ можно задавать определенные условия. Например, чтобы посчитать, сколько мы заработали на яблоках, привезенных именно с Греции, нужна вот такая формула:
=СУММПРОИЗВ((В:В=»Яблоко»)*(С:С=»Греция»);Е:Е;G:G)

Для того чтобы растянуть формулу СУММПРОИЗВ потяните за привычный правый нижний угол ячейки. После этого обязательно нужно посмотреть, какие диапазоны используются в аргументах.

Поскольку я растянула только на одну ячейку, то и столбцы сместились на это же количество, и теперь в формуле перемножаются F и H . Учитывая, что все строки в столбце H пусты, результат получился нулевой.

Представьте, что нам нужно перемножить и просуммировать E с G и F с G . Поэтому в J4 исправляем аргумент H на G .

Если Вы растянули формулу не на одну, а скажем 10 ячеек, то исправлять не совсем удобно. Поэтому лучше закрепить тот столбец, который используется в расчете постоянно. В примере это G и на него нужно сделать абсолютную ссылку. В первой ячейке с расчетами, у меня это I4 , ставим перед G знак «$» , чтобы получилось $G4:$G10 . Теперь растягивайте. Из примера видно, что в аргументах столбец E сменился на F , а вот G так и остался.

Используйте любой из способов, и у Вас точно получится рассчитать сумму произведений в Эксель.

Функция СУММПРОИЗВ() — Сложение и подсчет с множественными условиями в MS EXCEL

Функция СУММПРОИЗВ() , английская версия SUMPRODUCT(), не так проста, как кажется с первого взгляда: помимо собственно нахождения суммы произведений, эта функция может использоваться для подсчета и суммирования значений на основе критериев, а также, в некоторых случаях, избавить от необходимости применений формул массива.

Существует несколько вариантов применения функции СУММПРОИЗВ() :

  • нахождение суммы произведений элементов списка (массива);
  • суммирование и подсчет значений, удовлетворяющих определенным критериям;
  • замена формул массива (в некоторых случаях).

Нахождение суммы произведений элементов массивов

В этом разделе показан синтаксис функции СУММПРОИЗВ() и раскрыт ее потенциал для других применений.

Пусть имеется 2 диапазона чисел A3:A6 и B3:B6, содержащие соответственно 2 массива чисел: <4:8:6:1>и <7:6:7:5>. Записав формулу =СУММПРОИЗВ(A3:A6;B3:B6) , получим 123. Результат получен поэлементным перемножением всех элементов двух массивов, а затем сложением полученных произведений. То есть были выполнены следующие арифметические действия: 4*7 + 8*6 + 6*7 + 1*5= 123

Таким образом, можно найти сумму произведений 3-х, 4-х и т.д. массивов.

Читать еще:  Как работать в эксель с таблицами формулы

Аргументы, которые являются массивами, должны иметь одинаковые размерности (в нашем случае это массивы по 4 элемента). В противном случае функция СУММПРОИЗВ() возвращает значение ошибки #ЗНАЧ!.

В формуле =СУММПРОИЗВ(A3:A6;B3:B6) функция СУММПРОИЗВ() трактует нечисловые элементы массивов как нулевые. Однако, как показано ниже, функцию можно использовать для подсчета текстовых значений.

Что произойдет если указать только 1 массив, т.е. =СУММПРОИЗВ(A3:A6) ? Тогда функция СУММПРОИЗВ() вернет сумму элементов, т.е. будет эквивалентна функции СУММ() : =СУММ(A3:A6) .

Синтаксис функции СУММПРОИЗВ() позволяет не просто указывать в качестве аргумента определенный диапазон, но и осуществлять арифметические действия перед операцией суммирования. Например, записав:

  • =СУММПРОИЗВ(A3:A6*2) , получим сумму произведений =38 (каждый элемент массива из A3:A6 был умножен на 2, затем все произведения просуммированы);
  • =СУММПРОИЗВ(A3:A6*B3:B6) , получим результат суммы произведений – 123 (все элементы массивов были попарно перемножены, а затем сложены, т.е. A3*B3+ A4*B4+ A5*B5+ A6*B6), т.е. эта запись эквивалента формула =СУММПРОИЗВ(A3:A6;B3:B6) ;
  • =СУММПРОИЗВ(A3:A6+B3:B6) , получим сумму элементов из двух диапазонов;
  • =СУММПРОИЗВ(A3:A6/B3:B6 ), получим сумму попарных отношений всех элементов, т.е. 4/7 + 8/6 + 6/7 + 1/5= 2,9619

Аналогичные вычисления можно выполнить и с функцией СУММ() , только для этого нужно ее ввести как формулу массива, т.е. после ввода функции в ячейку вместо ENTER нажать CTRL+SHIFT+ENTER: =СУММ(A3:A6/B3:B6)

Прелесть функции СУММПРОИЗВ() в том, что после ввода функции в ячейку можно просто нажать ENTER, что снимает некий психологический барьер перед использованием формул массива.

Оказывается, что в качестве аргумента этой функции можно указать не только произведение массивов ( A3:A6*B3:B6 ), но и использовать другие функции и даже применить к массивам операции сравнения, т.е. использовать ее для сложения чисел, удовлетворяющих определенным условиям.

Суммирование и подсчет значений удовлетворяющих определенным критериям

Попробуем подсчитать число значений больших 2 в диапазоне A3:A6, содержащий значения 4, 8, 6, 1.

Если мы запишем формулу =СУММПРОИЗВ(A3:A6>2) , то получим результат 0. Выделив в Строке формул A3:A6>2 и нажав клавишу F9, получим массив <ИСТИНА: ИСТИНА: ИСТИНА: ЛОЖЬ>, который говорит, что мы движемся в правильном направлении: в диапазоне A3:A6 больше 2 только первые 3 значения. Хотя значению ИСТИНА соответствует 1, а ЛОЖЬ – 0, мы не получим 3, т.к. для перевода значений ИСТИНА/ЛОЖЬ в числовую форму требуется применить к ним арифметическую операцию. Для этого можно, например, применить операцию двойного отрицания (—), что позволит привести массив в числовую форму <1:1:1:0>.

Итак, задача подсчета значений больше 2 решается следующим образом: =СУММПРОИЗВ(—(A3:A6>2))

Вместо двойного отрицания можно использовать другие формулы: =СУММПРОИЗВ(1*(A3:A6>2)) или =СУММПРОИЗВ(0+(A3:A6>2)) или даже так =СУММПРОИЗВ((A3:A6>2)^1) .

Запись >2 является критерием, причем можно указать любые операции сравнения ( =; =).

Критерии можно указывать в форме ссылки: =СУММПРОИЗВ(—(A3:A6>G8)) – ячейка G8 должна содержать число 2.

Критерии можно применять и к текстовым значениям, например, =СУММПРОИЗВ(—(B3:B6=»яблоки»)) – вернет количество ячеек, содержащие слово яблоки (подробнее, например, в статье Подсчет значений с множественными критериями (Часть 1. Условие И)).

Функцию СУММПРОИЗВ() можно использовать для отбора значений по нескольким критериям (с множественными условиями). Как известно, 2 критерия могут образовывать разные условия:

  • Условие ИЛИ. Например, подсчитать ячеек содержащих значение яблоки ИЛИ груши =СУММПРОИЗВ((B3:B6=»яблоки»)+ (B3:B6=»груши») ) ;
  • Условие И. Например, подсчитать количество значений больше 2 и меньше 5: =СУММПРОИЗВ((A3:A6>2)* (A3:A6 2)* (A3:A6 СРЗНАЧ(A3:A6))*(A3:A6)) сумма значений, которые больше среднего.

Примеры функции ПРОИЗВЕД для произведения расчетов в Excel

Функция ПРИЗВЕД принимает в качестве аргументов два массива, содержащих как минимум по одному элементу, которые являются числовыми значениями, и возвращает результат перемножения (произведение) всех чисел, содержащихся в массивах.

Например, запись =ПРОИЗВЕД(B1;C1) эквивалентная записи =B1*C1. Если были переданы ссылки на диапазоны ячеек =ПРОИЗВЕД(C7:C9;D7:D9), такая запись соответствует перемножению всех чисел в ячейках: =C7*C8*C9*D7*D8*D9. Как видно, функция ПРОИЗВЕД обеспечивает удобство выполнения операции произведения над числами, содержащимися в большом количестве ячеек. Несмотря на свою простоту эта функция открывает широкие возможности в Excel.

Произведение корней квадратного уравнения в Excel

Пример 1. В таблице содержатся числовые данные (несколько строк и столбцов). Вычислить корень квадратный произведения всех указанных чисел.

Вид таблицы данных:

Для расчета используем следующую формулу:

=0;КОРЕНЬ(ПРОИЗВЕД(A2:D5));»отрицательное число»)’ class=’formula’>

Поскольку корень отрицательного числа вычислить нельзя, используем функцию ЕСЛИ для проверки данных (результата вычисления функции ПРОИЗВЕД, принимающей ссылку на диапазон ячеек с числовыми данными в качестве единственного аргумента). Если полученное число является положительным или нулем, будет вычислен корень, иначе – выведено сообщение об ошибке.

Как видно в данном примере возможности функции весьма существенны. Далее рассмотрим более практичный пример применения вычислений подобного рода.

Расчет вероятности комбинаций в покере в Excel

Пример 2. В колоде находятся 52 карты 4 разных мастей (всего по 13 карт). Определить вероятность события, когда из колоды последовательно вытаскивают и возвращают обратно 4 карты различной масти.

Читать еще:  Excel в формуле не равно

Вид таблицы данных:

Для расчета используем умножение вероятностей для определения логического произведения событий (то есть, их одновременное наступление). То есть, необходимо определить вероятности четырех событий (например, вытащена пика, трефа, черва и бубна) и найти их произведение.

Вероятность первого события равна 1, поскольку карта любой масти будет уникальной (предшествующих событий нет). Вероятность второго и последующих событий определяется соотношением общего числа карт оставшихся мастей к числу карт во всей колоде, то есть 13 (число карт одной масти) * 3 (число оставшихся мастей)/52 – вероятность второго события.

Определим искомые вероятности в Excel с помощью формул:

Вычислим искомую вероятность с помощью функции:

  • 1 – определенная ранее вероятность первого события;
  • C4:C6 – диапазон ячеек с вероятностями последующих событий.

Подобная запись (наличие чисел и ссылок на ячейки в качестве аргументов функции) также является допустимой.

Правила использования функции ПРОИЗВЕД в Excel

Функция имеет следующий синтаксис:

=ПРОИЗВЕД( число1; [число2];…)

  • число1 – обязательный для заполнения, принимает числовое значение, ссылку на ячейку или диапазон ячеек с числовыми данными, которые необходимо перемножить;
  • [число2];… — второй и последующие необязательные аргументы, которые принимают числовые значения или ссылки на ячейки с числами, выступающими в роли второго и последующим множителей. Если явно не указан, принимается значение, равное 1. Например, =ПРОИЗВЕД(5) эквивалентно =5*1 и возвращает число 5. Максимальное число аргументов – 255.
  1. Функция выполняет промежуточные преобразования данных там, где это возможно, например, текстовые представления чисел, логические ИСТИНА и ЛОЖЬ. Например, =ПРОИЗВЕД(“3”;”6”) вернет значение 18, =ПРОИЗВЕД(3;ЛОЖЬ) вернет значение 0 (так как логическое ложь соответствует числовому 0).
  2. Если аргументы рассматриваемой функции указаны в виде ссылок на диапазоны ячеек, в некоторых из которых содержатся не преобразуемые к числам данные, функция исключит эти данные из расчетов. Например, результатом выполнения =ПРОИЗВЕД(A1:A4;B1:B4) будет число 144 ( в ячейках A1:A4 содержатся данные: 1, 2, 3, “текст”, в ячейках B1:B4 содержатся числа: 1, 2, 3, 4 соответственно).

Сумма произведений в Excel

В Microsoft Excel можно проводить разные расчеты, от самых элементарных до более сложных, где задаются определенные условия. Вот и задачу, которую мы с Вами сейчас рассмотрим можно решить по-разному.

В этой статье я покажу, как рассчитать сумму произведений в Excel различными способами: используя привычные «+» и «*», ссылаясь на определенные ячейки или с помощью функции СУММПРОИЗВ.

Возьмем следующий пример: умножим пары чисел, а затем просуммируем их самым простым способом.

Поставьте в ячейку «=» и начните вписывать значения, расставляя между числами знаки суммы и умножения. Эксель посчитает по законам математики – сначала умножит, а потом прибавит. Чтобы получить результат, жмите «Enter».

Если у Вас все значения были записаны как и в примере в А1, то можно не переписывать, достаточно выделить ячейку и поставить в строке формул знак равенства в самом начале.

Еще один вариант – это ссылаться на определенные ячейки, которые берутся для расчета. Преимущества такого способа в том, что если у Вас поменяются значения, например, в заполненной таблице, то сумму произведений не придется исправлять вручную, меняя там числа, все произойдет автоматически.

Для этого поставьте знак равно и выделяйте мышкой ячейки, расставляя между их адресами «+» или «*». Потом нажмите «Enter».

Теперь если я изменю в С1 число 24 на 3, результат в D6 будет пересчитан.

Для расчета суммы произведений в Эксель так же есть специальная формула – СУММПРОИЗВ. Ее использование перед предыдущими способами очевидны: автоматический расчет значений при их изменении, возможность задавать определенные условия, работа с большими массивами.

Примеры СУММПРОИЗВ в Excel, я приводила в отдельной статье, там же и рассказывала, как ей пользоваться.

Давайте возьмем такую таблицу. Посчитаем, сколько заработали, умножив количество проданных фруктов на цену реализации за килограмм. Для этого нужно записать формулу такого вида, указав в качестве аргументов нужные диапазоны со значениями:

Если у Вас таблица с большим количеством строк, то можно сделать и по-другому. В качестве аргументов для функции указывайте все столбцы полностью: (E:E;G:G). Теперь перемножаются 10 и 216, 5 и 114, 8 и 96 и так далее.

В аргументах к СУММПРОИЗВ можно задавать определенные условия. Например, чтобы посчитать, сколько мы заработали на яблоках, привезенных именно с Греции, нужна вот такая формула:

Читать еще:  Сумма прописью формула эксель

Для того чтобы растянуть формулу СУММПРОИЗВ потяните за привычный правый нижний угол ячейки. После этого обязательно нужно посмотреть, какие диапазоны используются в аргументах.

Поскольку я растянула только на одну ячейку, то и столбцы сместились на это же количество, и теперь в формуле перемножаются F и H. Учитывая, что все строки в столбце H пусты, результат получился нулевой.

Представьте, что нам нужно перемножить и просуммировать E с G и F с G. Поэтому в J4 исправляем аргумент H на G.

Если Вы растянули формулу не на одну, а скажем 10 ячеек, то исправлять не совсем удобно. Поэтому лучше закрепить тот столбец, который используется в расчете постоянно. В примере это G и на него нужно сделать абсолютную ссылку. В первой ячейке с расчетами, у меня это I4, ставим перед G знак «$», чтобы получилось $G4:$G10. Теперь растягивайте. Из примера видно, что в аргументах столбец E сменился на F, а вот G так и остался.

Используйте любой из способов, и у Вас точно получится рассчитать сумму произведений в Эксель.

Как не забивать гвозди микроскопом с функцией СУММПРОИЗВ

Стандартное использование

Базовый синтаксис нашей функции прост:

=СУММПРОИЗВ( Массив1 ; Массив2 ; . )

Самый скучный вариант использования этой замечательной функции — применять ее так, как описано в справке — для суммирования попарных произведений ячеек в двух (и более) указанных диапазонах. Например, можно без дополнительного столбца расчитать общую стоимость заказа:

По сути, то, что делает эта функция можно выразить формулой:

= B2*C2 + B3*C3 + B4*C4 + B5*C5

Технически, перемножаемых массивов (диапазонов) может быть не два, а три или больше (до 255). Главное, чтобы они были одного размера. Удобно, но ничего особенно. Однако, использовать СУММПРОИЗВ только так — забивать гвозди микроскопом, ибо, на самом деле, она умеет гораздо больше.

Работа с массивами без Ctrl+Shift+Enter

Если вы хоть немного знакомы в Excel с формулами массива, то должны понимать их мощь и красоту. Иногда одна формула массива может заменить несколько столбцов дополнительных вычислений и ручного труда. Но у формул массива есть и минусы. Главные — это относительная сложность понимания, замедление пересчета книги и необходимость вводить эти формулы сочетанием Ctrl+Shift+Enter вместо обычного Enter. И вот как раз с последним может помочь наша функция СУММПРОИЗВ. Нюанс в том, что она умеет работать с массивами по определению, т.е. не требует обязательного нажатия Ctrl+Shift+Enter при вводе.

На этом факте основано большинство трюков с использованием СУММПРОИЗВ (SUMPRODUCT) . Давайте, для примера, рассмотрим пару-тройку наиболее характерных сценариев.

Подсчет количества выполненных условий

Допустим, нам нужно посчитать количество филиалов компании, где план выполнен (т.е. факт больше или равен плану). Это можно сделать одной формулой с СУММПРОИЗВ без дополнительных столбцов:

Умножение на 1, в данном случае, нужно, чтобы преобразовать результаты сравнения плана и факта — логическую ИСТИНУ и ЛОЖЬ в 1 и 0, соответственно.

Проверка нескольких условий

Если нужно проверять больше одного условия, то формулу из предыдущего примера нужно будет дополнить еще одним (или несколькими) множителями. И если нужно подсчитывать не количество, а сумму, то умножать можно не на 1, а на диапазон с суммируемыми данными:

Фактически, получается что-то весьма похожее на математическую функцию выборочного подсчета СУММЕСЛИМН (SUMIFS) , которая также умеет проверять несколько условий (до 127) и суммировать по ним значения из заданного диапазона.

Логические связки И и ИЛИ (AND и OR)

Если нужно связывать условия не логическим «И», как в примере выше (Факт>=План) И (Регион=Восток) , а логическим ИЛИ, то конструкция немного изменится — знак умножения заменяется на плюс:

Подсчет по данным из закрытого(!) файла

Кроме всего вышеперечисленного, у СУММПРОИЗВ есть еще одно неочевидное и весьма полезное свойство — она умеет работать с данными из неоткрытых книг. Если, для сравнения, попробовать подсчитать в другом файле количество филиалов из региона Восток нашей книги и написать вот такое:

. то вторая формула с классической функцией СЧЁТЕСЛИМН (COUNTIFS) будет работать только до тех пор, пока исходный файл открыт. Если его закрыть, то появляется ошибка #ЗНАЧ! Наша же функция СУММПРОИЗВ (SUMPRODUCT) спокойно считает по данным даже из неоткрытой книги!

Похожие статьи

Ссылка на основную публикацию
Похожие публикации
Adblock
detector